I am building an ASP.NET Web Forms application (not site) and whenever I debug with Internet Explorer, I cannot seem to disable the integrated Javascript debugging with Visual Studio 2013 Pro.

How do I get it to stop breaking on Javascript exceptions?

My OS is Windows 2012 Server R2 (so, equivalent to Windows 8.1 Pro) with IE11. I have tried every setting that I could find but nothing has worked so far. I have even logged out and back in. I am going to try a complete reboot right now.

The screenshots below show all the settings I've tried.

Exception and Settings:

Exception Occurrence and Settings


Visual Studio Options - Debugging:

Visual Studio Debugging Options


Internet Explorer Options:

Internet Explorer Options


BrowserLink Disabled

BrowserLink Options


(Note: This question was also posted at stackoverflow.com. I'm not sure where it belongs.)

  • 1
    You're confusing uncaught vs thrown. Also, why not fix your code? ;) – Daniel B Aug 27 '14 at 22:04
  • It's not my code, but I did fix it thanks :) – Wayne Bloss Aug 27 '14 at 22:48
  • I guess my main concern is - I have checked "Disable script debugging" in Internet Options and it's not working. I disabled everything else in an attempt to see what gives. – Wayne Bloss Aug 27 '14 at 22:49
  • this is a coding/developer tool issue so imho it should be only asked on stackoverflow. – magicandre1981 Aug 28 '14 at 4:27
up vote 2 down vote accepted

The options in VS for exceptions to determine if the debugger should break on an exception. Though VS will always break on an unhandled exception and a language break (debugger). The options do not stop the script debugger from being attached when you launch IE from VS.

The options in VS to enable or disable JIT debugging change just the just-in-time debug feature. Enabling JIT debug simply means that if a running application not launched by VS hits a break condition the user should be prompted if they want to attach VS to debug the application. This also don't change if script debugging is enabled when you launch IE from VS.

The options in Internet Explorer to disable script debugging only changes if IE should run with debugging enabled always. In IE11 with VS2013 this feature is never needed but is there to support older versions of VS.

The easiest way to get the behavior you want is to do:

  1. Right click on a aspx/html file there is a ‘Browse with…’ item. This will bring up a dialog to configure your browser.
  2. Click the Add button. Add something like:

        Path: c:\Program Files (x86)\Internet Explorer\iexplore.exe 
    
        Friendly name: Internet Explorer (no debug)
    
  3. Set that as your default
  • It sounds like the bottom line is - don't start IE from VS-debug if I don't want the debugging to occur. – Wayne Bloss Aug 29 '14 at 2:43
  • 1
    @waynebloss pretty much but if you use Ctrl+F5 to launch IE without debugging you'll also not be debugging your managed asp.net code. Which you may or may not want. – Andy Sterland Aug 29 '14 at 21:50

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.