19

My remote desktop session is refusing to use both monitors. Here's how they are laid out enter image description here

I do have the option checked in the Remote Desktop Connectionenter image description here

What else can I do?

5
  • Is that screenshot a layout of the desktop from which you are trying to connect, or the machine you are trying to RDP into? In what way is it "refusing to use" then monitors exactly? Assuming what's pictured is the Windows 8 you are connecting from, what is the Windows version on the machine you are trying to connect to? Aug 28, 2014 at 13:18
  • The screenshot is the machine I am trying to connect from. I am connecting from a windows 8 laptop (2 external monitors) to a windows 7 laptop.
    – PBG
    Aug 28, 2014 at 13:27
  • Which version/edition of windows 7 are you attempting to connect to? Aug 28, 2014 at 16:57
  • Windows 7 professional
    – PBG
    Aug 28, 2014 at 20:49
  • 4
    They should have at least disabled that checkbox so that we know upfront it's not supported instead of us chasing our tails and spending a lot of time troubleshooting this somewhere else in the system! Nov 5, 2015 at 19:35

4 Answers 4

20

Multiple monitor support in RDP is only supported for Windows 7 Ultimate and Enterprise according to Remote Desktop Connection: frequently asked questions . Only the connecting client needs to have Ultimate or Enterprise, the remote host can have Windows 7 Professional.

Have you tried passing /span to mstsc as mstsc /span? It's a bit clunkier than full multi monitor support as it all appears as one monitor on the windows 7 system but might work for your purposes along with something like splitview...

5
  • I want it to show up as two monitors, so /span isn't an option.
    – PBG
    Aug 28, 2014 at 20:50
  • 2
    Multiple monitors are not supported on Windows 7 Pro as mentioned in the FAQ I linked to in my answer. I believe span + splitview will be as close as you get. Aug 28, 2014 at 21:06
  • I ended up here, because "mstsc /span" isn't working. It still stays on one monitor. I'm using duel monitors from an HP docking station. One is connected via DVI, the other is connected via HDMI. Doesn't seem to matter what I do, span won't work. Both monitors are DELL 32" LCDs with latest drivers installed.
    – maplemale
    Feb 15, 2016 at 18:16
  • I would expect span to work, as that's a standard feature. You might try using explict /w:<Width> /h:<Height> options rather than span or posting a question describing your specifics. Feb 16, 2016 at 3:19
  • As an alternative I use this or this. Works invisibly with the normal rdp client and is very stable.
    – Praesagus
    Mar 14, 2016 at 19:24
6

I think there is a solution.... RDP Wrap https://github.com/binarymaster/rdpwrap/releases https://github.com/stascorp/rdpwrap/releases

(Search google for rdp wrap or rdp wrapper to get more info about what it does/how it works)

Basically, this software can be used with Home versions of Windows(7) to allow remote desktop sessions, and multiple sessions. I had installed it in that manner, and just noticed that if I connect to machine (running Windows 7 Home Premium) with this wrapper and tick the checkbox on the remote client to use all available monitors for the RDP session - IT WORKS!! I have 3 monitors and they are all active in the session and this is in true multi-mode not the stupid split-screen. So, I think it would work in similar fashion on Win 7 Pro.

3
  • 1
    Sweet! I ran install.bat on the host PC & remote PC, reran RDP, and it worked! Thanks! :) Aug 2, 2016 at 14:26
  • This is great. I've been frustrated with this for about 3 years with my cheap ass company refusing to upgrade my OS. Finally I'm productive again when working remotely.
    – Shay
    Aug 13, 2016 at 0:22
  • You are my savior! This is so great to have since it's now impossible to upgrade to Ultimate or Enterprise. Aug 15, 2016 at 13:49
1

I found that when using /span, I was able to use two monitors when logged into work from home. Then I changed my monitor config, and it stopped working!

I read this article here, https://www.hanselman.com/blog/how-to-remote-desktop-fullscreen-rdp-with-just-some-of-your-multiple-monitors

Scott mentioned that if you use mstsc /l, it lists your monitors and their positions. I found my first monitor one was at 0,0 and the second was at 1024,4 (should be 1024,0) - That misalignment was fixed by dragging the window up and down to snap in the windows 10 display settings - then /span worked again!

0
0

I can't seem to link this comment to others about the "mstsc /span" command. I could be wrong but my experience with "mstsc /span" That it is a mirror of local pc to remote pc. (I just did a remote from win10 to win7 pro.) My findings are if your local pc has 2 screens, it pushes to remote you have 2 & stretches to match. example: if you local has 3 the rdp session will show 3.
If your local has one but you have a large 30" it will strectch to that size.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .