7

I just started using Microsoft Virtual WiFi or hostednetwork from Command Prompt to share my internet connection through my WiFi adapter and it's good so far! The only issue I face however is that I can't find a way to display the assigned IP addresses to the clients connected to the Virtual WiFi, is this possible? If not, then how can I get the range of IPs that the client should have been assigned to when the client connected to the Virtual WiFi?

I can see the clients on "My Network Places" however, from the client machine, when I see the assigned IP and try to ping it from the machine hosting the Virtual WiFi I get no response. So how can I get the client IP address in order to ping/connect to the client?

Example: On my client's machine when I do ipconfig it shows an empty value for Default Gateway and the IP address is 192.168.137.1. However when I go to the machine which hosts the Virtual WiFi and ping that IP, I get no response

Edit: typing netsh wlan show hostednetwork shows the current status of the Virtual WiFi, it also shows the MAC addresses of the connected clients, however it doesn't show the IPs unfortunately. Example:

> netsh wlan show hostednetwork
Hosted network settings
-----------------------
    Mode                   : Allowed
    SSID name              : "Giovanni-PC"
    Max number of clients  : 100
    Authentication         : WPA2-Personal
    Cipher                 : CCMP

Hosted network status
---------------------
    Status                 : Started
    BSSID                  : 56:5a:04:6f:88:09
    Radio type             : 802.11n
    Channel                : 11
    Number of clients      : 1
        00:19:32:45:71:da        Authenticated <-- (a client)

Edit 2: On the client's machine, there's no value for Default Gateway. I'm also not sharing an internet connection, I just want to connect to the client's machine through FTP to copy data, could this be the problem?

  • Be aware that windows firewall, at least on windows 7 blocks incoming ping, so not being able to ping it doesn't necessarily mean you can't connect to it. – user2313067 Aug 28 '14 at 16:40
  • @user2313067 I was aware of that, I even turned off the firewalls but still didn't work; I didn't block ICMP requests, and ICMP requests aren't blocked by default. So there were no connection at all, making Windows XP as the host machine however fixed the issue, not really sure what caused this. – Giovanni Mounir Aug 29 '14 at 8:29
9

I've also had this problem, and I solved it like this:

  • create a WiFi hotspot:

    netsh wlan set hostednetwork mode=allow ssid=ProvaMi key=pippo123

    netsh wlan start hostednetwork

  • Assign the hotspot a name in the "Network and sharing center > change adapter settings" (in my case: "TestWIFI")

  • Set a static IP address for the WiFi network:

    netsh interface ip set address "TestWIFI" static 192.168.159.1 255.255.255.0 196.168.159.1

Now, using a program that provides a DHCP server on windows (http://www.dhcpserver.de/cms/), I configured the server to generate the

[SETTINGS]
IPPOOL_1=192.168.159.2-254
IPBIND_1=192.168.159.1
AssociateBindsToPools=1

Now, the DHCP server will update its own settings file (dhcpsrv.ini) with the IP address and the DNS name of any connected client.

Hope this helps.

Note: all the above (IP addresses, passwords, etc.) are examples for my test configuration. Of course you'd need to use your own settings.

  • 2
    "...of course you'd need to use your own settings." --- Ok, I'm a newbie here, but what should my own settings be? Based on what? How do I choose an IP, a gateway? What are the rules for the "hosted network" and the client's ip/gateway/DNS? – Daniel Möller Jul 6 '16 at 21:51
  • Actually any number can be use since this is just local usage. But mostly in common we always seen ip start with 192.168.XXX.XXX in anywhere regarding to IP address especially TP-LINK / DLink home router. So we could follow that number. Now if you have done started up your hostednetwork, you could type "ipconfig" in command promp windows. And you should saw your ip address is already here and just use that ip. follow Nova's answer accordingly with your own ip address. About subnet mask, please use 255.255.255.0. – elliotching Mar 10 at 8:02
4

arp -a will dump out your arp (or Address Resolution Protocol) tables - this is the mapping of ip addresses to mac address

then look for all dynamic addresses under the interface you are using - the output looks something like this/

Interface: 192.168.0.106 --- 0xe
  Internet Address      Physical Address      Type
  192.168.0.1           c4-a8-1d-84-f3-59     dynamic
  192.168.0.101         00-1e-8f-76-95-5e     dynamic
  192.168.0.105         00-10-75-57-7a-e8     dynamic
  192.168.0.126         00-1c-25-20-1a-a0     dynamic
  192.168.0.255         ff-ff-ff-ff-ff-ff     static
  224.0.0.22            01-00-5e-00-00-16     static
  224.0.0.251           01-00-5e-00-00-fb     static
  224.0.0.252           01-00-5e-00-00-fc     static
  224.0.0.253           01-00-5e-00-00-fd     static
  239.2.0.252           01-00-5e-02-00-fc     static
  239.192.152.143       01-00-5e-40-98-8f     static
  239.255.255.250       01-00-5e-7f-ff-fa     static
  255.255.255.255       ff-ff-ff-ff-ff-ff     static
  • This answer might be correct but it needs some fleshing out. E.g. Why does that work? What does it do. Tell that arp -a shows the arp cache, etc etc – Hennes Feb 23 '16 at 12:48
  • In conjunction with netsh wlan show hostednetwork, this gives me the IPs of clients which is what I came here looking for – katriel Mar 31 '16 at 8:42
  • in windows 10 you can get the list for single interface: arp -a -N 192.168.137.1 – Alec Istomin Nov 26 '17 at 7:05
0

You need to use ipconfig /all and browse to Wireless LAN Adapter. Look for IPv4 Address.

  • On which device? I looked on the client and did so, it showed: DHCP Enabled: No, IPv4 Address: 192.168.137.1. However trying to ping that IP address from the host machine doesn't work. Any thoughts? – Giovanni Mounir Aug 28 '14 at 14:08
  • Run this command on the host machine. – DragoonHP Aug 28 '14 at 14:09
  • IP Address on host machine is: 192.168.173.1. Host enabled: Yes. Autoconfiguration Enabled: Yes. – Giovanni Mounir Aug 28 '14 at 14:10
  • You should see something like this: i.imgur.com/SdAAIiW.png – DragoonHP Aug 28 '14 at 14:13
  • 1
    Just worked on my Windows XP! I can ping the machine's IP now! Although on Windows 7 this wasn't possible, I think it was a problem with the client machine anyways. This time I used Windows XP to host the adhoc network however; Windows 7 as a host machine caused the same issue. Thank you for all your help! – Giovanni Mounir Aug 28 '14 at 15:05

protected by Community Aug 19 '16 at 3:00

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.