5

I'm getting the error code: DNS_PROBE_FINISHED_NO_INTERNET in Google Chrome. The thing is, I have a working internet connection. I am posting this using that connection, using Internet Explorer. It's only Chrome doing this.

What happened was my laptop was refusing to go to sleep mode, so it ended up running out of battery power. I charged it, and when I subsequently booted the computer, Chrome stopped working. I don't see the connection...

I added Firewall rules (inbound/outbound) to allow Chrome to connect...so unless I'm missing something.

UPDATE: Chrome portable is working for me...just not the regular chrome.

UPDATE 2 Now I realize it had to do with Covenant Eyes which I have installed. See the accepted answer

9
5

The problem is likely related to Chrome and a black list service that is new and apparently not ready. The blacklist service (wrongly) blocks some dll's, most common being one that is used by an internet filtering software called Covenant Eyes. According to Covenant Eyes customer support, the problem only exists on versions 4.5.3 and earlier. Upgrading to version 5, which requires a full uninstall of the previous version, will fix the issue.

There is a workaround that involves a simple registry edit. This is useful if you cannot upgrade Covenant Eyes for some reason or your issue is related to the Chrome blacklist service, but not Covenant Eyes.

Change registry value HKEY_CURRENT_USER\Software\Google\Chrome\BLBeacon\state from 1 to 0.

The registry edit workaround has mixed reviews on this page. Some say it works, but reverts back after closing Chrome. Others report that it works perfectly and they can close Chrome and it will not revert. The reason is not clear, but most with the Covenant Eyes issue are reporting that it is working perfectly for them. A few users without the Covenant Eyes issue have reported that the registry edit worked for them as well.


  1. I have personally tried the Regedit option and it worked and has not reverted after five days of heavy use. I have not tried upgrading Covenant Eyes. I will try that on a different computer without making the registry edit and report back.
  2. How to use the registry editor. Be cautious when using the registry editor. If you don't know what you are doing you can really mess up your computer.
5
  • On Sep. 24th, I had to redo the regedit option for the first time, but on all my computers. Chrome must have had a minor background update that switched the registry value back to 1. I still have not upgraded Covenant Eyes. – 287352 Sep 26 '14 at 17:45
  • It is now January, I have still not upgraded Covenant Eyes. I've not had any problems since. – 287352 Jan 9 '15 at 23:48
  • Almost a year later and I've switched to FireFox for other reasons. Chrome does still seem to work, when I do use it, however. Covenant Eyes is not updated still. – 287352 Jul 28 '15 at 3:24
  • I've now switched back to Chrome and Covenant Eyes version 4.5.3 has not given me any problems. Chrome: Version 48.0.2564.97 m (64-bit) Windows 7 – 287352 Feb 2 '16 at 18:52
  • 1
    Just ran into this with Chrome v58.0.3029.96 and Covenant Eyes v7.2.11. Registry fixed worked and (so far) has survived multiple starts of Chrome. – I say Reinstate Monica May 16 '17 at 17:46
1

Norton 360 Premier Edition has caused me problems in the past and I just had it happen again. Turned off Smart Firewall and Chrome started working. So I turned it back on and Chrome wouldn't work. Went to Programs in Norton and enabled Google Chrome and it works fine now.

1

We found that mostly the people in our team who had VirtualBox installed on their machines were facing this problem i.e. they were able to connect to internet through other browsers but not through Chrome. So, if you have also installed VirtualBox at some point of time, it is worth checking the settings mentioned below. it could be one of the causes of the issue. Solution: Disabling the VirtualBox-Host-Only Network adapter worked for the team. It can be found at: Control Panel -> Network and Internet -> Network Connections enter image description here

2
  • 1
    He does not mention VirtualBox, how do you assume he is using it? – davidbaumann Feb 19 '19 at 6:24
  • There's no assumptions whatsoever in this answer ... – GChuf Aug 19 '20 at 6:35
1

Please check this url https://productforums.google.com/forum/#!topic/chrome/dCaJWaki0c4 There seems to be a solution for your issue

Excerpt from that thread:

Solved:

cmd (as administrator) -> netsh winsock reset

probably winsocket catalogue was corrupted

2
  • I tried this also, and it still didn't work. – robev Aug 29 '14 at 12:42
  • Worked for me. And I didn't have to reboot also. – Anonymous Person Aug 28 '16 at 15:25
0

The issue may be with your DNS cache. Try running ipconfig /flushdns from the Windows command prompt. If you have the UAC enabled, you may need an elevated command prompt session (right click on cmd.exe and select "Run as Administrator")

2
  • I've tried that, didn't do anything. Or do I need to do it and reboot? – robev Aug 29 '14 at 12:05
  • 1
    You shouldn't need to reboot. If flushing the dns cache didn't work, it probably isn't the problem after all. – lzam Aug 29 '14 at 12:17
0

I tried the options above but they didn't work. I had also noticed that IE had slowed down a bit. Then I remembered that there were several security patches to Microsoft Office that I recently installed and since nothing else worked, I uninstalled them. Since they were all done on the same date they were easy to find. It took awhile since there were a lot but once I removed them and rebooted, Chrome magically started working again and IE went back to its old speed again.

0

This shows you how to fix a fairly common problem that people on Windows 7, 8 and 8.1 and Windows 10 are having.

It involves your PC having a secure internet connection, but some of your browsers (e.g. Chrome, Firefox) won't work, and you cannot access the internet via these browsers.

There are 2 different solutions. The first one is the most common fix, and the second is a more rare issue.

Solution 1

Commands:

  • Start> Find or Search> Type " cmd"> Right click the CMD Icon> Select "Run as Admin..">
  • Copy & Paste and enter each of the following commands one at the time, then type EXIT > Enter > Restart Computer.

    1. netsh winsock reset catalog
    2. netsh int ip reset reset.log hit

Solution 2

DNS Check Website: https://dnscheck.pingdom.com/

-1

I suddenly had this problem and I realised that I had a WIRED internet connection AND a WIRELESS connection active and it seemed to be causing Chrome not to connect. Turned the WiFi off and it started working straight away!

Hope that helps someone!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.