I have OpenSuse installed alongside Windows 7. Grub is the boot loader from where I access OpenSuse and Windows 7.

I want to delete Grub and also the OpenSuse partitions.

My first, failed, approach was to insert the Win7 DVD, choose Repair your computer and then enter the commmand prompt. I then typed "bootrec /fixmbr" and restarted. It didn't worked. Grub was still there, so was Windows7. I then tried using "bootrec /fixboot and /rebuildbcd and neither worked.

So what can I do to fix this? I remember when I was using WinXP this was much simpler. I would just type fixmbr and that was it.

Any clues?


From Microsoft's support article 927932

To run the Bootrec.exe tool, you must start Windows RE. To do this, follow these steps:

  1. Put the Windows Vista or Windows 7 installation disc in the disc drive, and then start the computer.
  2. Press a key when you are prompted.
  3. Select a language, a time, a currency, a keyboard or an input method, and then click Next.
  4. Click Repair your computer.
  5. Click the operating system that you want to repair, and then click Next.
  6. In the System Recovery Options dialog box, click Command Prompt.
  7. Type Bootrec.exe, and then press ENTER.

Options are listed on the weblink.

 bootrec /fixmbr
 bootrec /fixboot
 bootrec /rebuildbcd

If the command bootrec /fixboot returns with message

The volume does not contain a recognized file system. . . . ."

Run the following command

  sel vol c          <===== make sure C:\Windows exists
bootrec  /fixboot
bootrec  /rebuildbcd
  • That doesn't help because GRUB takes over the boot, and I can't choose which OS to repair. It can't "see" Windows 7. I need to delete Grub2. – elvispt Dec 9 '09 at 16:01

I have no idea if this works with Win7 or even Vista, so you'll probably want to make a disc backup first, but in XP you could run the start of the install process (i.e up to the point the computer restarts) and then your existing install of XP would run.


OK I managed to solve my problem.

I chose to repair my computer, then chose to let Windows to it all automatically. By choosing the first option. It worked. Strangely it didn't work before when using bootrec tool when it should. Thanks anyway. :)

protected by nhinkle Sep 22 '11 at 22:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.