My system is Gentoo Linux (kernel is 3.16.0), my file system is reiserfs.

A couple days ago, I unpacked a big tarball which is more than 100MB, and is about 1.3GB and 10,000 files after unpack , then I found several unpacked files were disordered, uncompleted, corrupt. So I did fsck on that partition (/dev/sda9). File system error was found.

Comparing bitmaps..vpf-10640: The on-disk and correct bitmaps differs.
2 found corruptions can be fixed when running with --fix-fixable

So I did fsck again with --fix-fixable, it showed me successful at last. I thought it was OK, but no.

If I unpack that tarball again, the error happened again, despite how many times I did fsck with --fix-fixable, even with --rebuild-tree.

This tarball is all right, I unpack it on another partition (reiserfs too), no error. So I doubt if there are bad blocks on disk. I use command "badblocks -nsv" to check entire disk (/dev/sda), no bad blocks is reported. (Is the way checking bad blocks right?)

I tried re-format as well, unfortunately nothing good happened. (I backed all files on the "problem" partition up to another place, and re-format that partition (still reiserfs), then copied them back. The error appeared again after I unpacked that tarball again. I am sure that tarball is OK, because I tried other big tarballs, same error.)

So, now, I am very confusing, if there is no bad blocks on disk, why the file system gets broken over and over again after I fix it.

  • What filesystem are you using? There are some that get corrupted if you as much as look at them wrong... – grawity Aug 29 '14 at 7:49
  • I hate to ask, but: are you running fsck with the system running normally? Or are you unmounting ("umount"ing) the file system first (possibly by going into "single-user mode")? – G-Man Aug 29 '14 at 23:52
  • @grawity: Reiserfs. I mentioned... – Bruce Sep 1 '14 at 14:05
  • @G-Man: Of course... (You can not fsck partitions without unmounting them. Actually, I used a Live-DVD to boot my computer up and do all fsck-things, instead of my Gentoo Linux inside the hard disk. I am an experienced linux user...) – Bruce Sep 1 '14 at 14:11
up vote 2 down vote accepted

Have been being tortured by this problem for some weeks, I finally found the answer today.

Today, I suddenly had a flash of idea that maybe my hard disk has no problem at all, maybe it is a bug of reiserfs, a bug of my Linux kernel which is 3.16.0. So I google'd it and got the answer. Yes, it is bug of reiserfs in kernel 3.16.0 and 3.16.1.

See following links for details.
https://bugzilla.kernel.org/show_bug.cgi?id=83321
https://bugzilla.kernel.org/show_bug.cgi?id=83121

So, actually this is not a common question, it is just for a specific version of linux kernel. (And if you are using the buggy version kernel with reiserfs, upgrade it as soon as possible!)

  • And I think it can be closed right now. – Bruce Sep 2 '14 at 15:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.