2

Now I know that this issue has been discussed much around the web but most of the solutions focus Windows XP and/or are outdated. Some suggest updating video drivers, some say editing specific registry keys that don't exit in Windows 7/8, while others don't reply. So I'm posting this here, hoping my problem gets solved :)

Problem

The Direct3D acceleration for 32bit Windows applications is disabled. I need to enable this so that most games and Direct3D using Windows Store apps start working again.

What happened?

Previously, Microsoft WDDM v1.0 drivers were installed (from Windows Update) and the system had no problems. Everything was working, well, almost everything. That was when I installed Minecraft. As I launched it, an error popped up saying 'pixel format not accelerated'. I researched on that and found out that it was an OpenGL issue. I downloaded and launched GPU Caps Viewer and found out OpenGL v1.1 on my system, whereas Minecraft needed 1.4 or more to run. I further researched and found that the Microsoft's WDDM v1.0 drivers supported maximum OpenGL v1.1 (well, at least for my GPU). However on Intel's official site, it said my GPU CAN support OpenGL v1.4. And also on Minecraft forums someone said that Intel's drivers were needed for older GPU's in order for Minecraft to work. So I looked at the Download Center, but the latest drivers for my GPU were for Windows 7 32 and 64bit not Windows 8. Upon thinking that at least Windows 7 drivers would work on Windows 8 if not XP's or Vista's, I downloaded the Windows 7 x64 drivers. They installed without an issue. Restarted my PC. Checked GPU Cap Viewer again, and voila! OpenGL version 1.4 was displayed. I re-installed Minecraft and it worked like a charm! :) Also checked another OpenGL animation software Blender and it was also working. But then I noticed something. Some Windows Store games and apps were exiting as soon as opened them. Also all the desktop games I have e.g Warcraft showed some Direct3D or DirectX related error. All of these applications were 32bit.

I then opened up "dxdiag".

The 64bit version said "Enabled" for all three DirectDraw, Direct3D and AGP Texture acceleration.

But when I opened the 32bit one, first it said: "Error: Problem getting extra display info."

And then on the display tab, Direct3D acceleration was disabled.

For screenshot reference, see this link: http://www.eightforums.com/performance-maintenance/52766-enable-direct3d-acceleration-32bit-apps-windows-8-a.html

Solutions tried

1- As seen from some tutorials around the web, I went to Advanced Display settings but no troubleshoot tab was found. So yeah, no moving the slider to right side to give 'Full' Direct3D/Hardware acceleration. Those XP days are long gone. :)

2- As stated above, I have updated the video drivers to 'Intel's' latest version. (Also tried the second latest version just in case).

3- Updated the DirectX through web setup. It now says that newer or equivalent version is already installed. Also installed DirectX 9.0c (June 2010) all to no avail.

4- As referred by many people, I have checked this link: http://answers.microsoft.com/en-us/windows/forum/windows_7-gaming/direct3d-acceleration-is-not-available-in-windows/4c345e6e-dc68-e011-8dfc-68b599b31bf5 (look at the answer)

There is no "SoftwareOnly" registry key that I could change from 0 to 1. :(

5- Note that this problem persist only in 32bit Direct3D using applications NOT 64bit. The driver works well for the 64bit apps.

Now from what is stated above, it is clear that this issue caused by Intel's driver but it may also be a Windows problem too. And I think I am currently running out of options here. Please help if anyone can. WDDM drivers are nice but wouldn't it be great if you could have OpenGL v1.4 along with Direct3D enabled? So I could run things like Minecraft. As a side note, a year ago I had Windows 7 32bit installed having latest Intel's drivers and with Direct3D enabled without an issue. Now this problem either could be because of Windows 8 or drivers. Please give any helpful thoughts. Awaiting your replies.

Thank you for your patience. :)

P.S. If you want any DX logs or any other information, just comment below.

Specs

System Manufacturer/Model Number: Dell Inc. Optiplex(TM) GX620
OS: Microsoft(R) Windows 8 x64
CPU: Intel(R) Pentium(TM) D 925 3.0 GHz
Memory: Samsung DDR2 2 GB 300 MHz
Graphics Card: Integrated Intel(R) 82945g Express Chipset Family 256 MB

  • A rather similar question is asked here: superuser.com/questions/135374/… – Silver Falcon Aug 29 '14 at 17:50
  • No help yet? Well I can live without Minecraft on this system. For now I am reverting back to WDDM 1.0. One last thing that I have observed: The display tab on DirectX Diagnostic Tool shows two dlls, "igdumd64.dll" and "igdumd32.dll", on WDDM 1.0 drivers. While on the 64bit Intel drivers, it only showed "igdlh64.dll". Maybe thats why the 32bit applications weren't working. Well, thats it for now. Good bye. :) – Silver Falcon Aug 29 '14 at 17:51
  • What’s “some Direct3D or DirectX related error”, exactly? – Daniel B Aug 29 '14 at 18:06
  • @DanielB Well it was something like Direct3D capable adapter wasn't found for one game and something similar for another. Believe me, any thing 32bit and D3D based wasn't running. Doesn't matter be it a Windows Store App or be it Win32 desktop application. I have heard that Windows 8 is itself based on D3D display but since I have 64bit of it, along with 64bit drivers, therefore it was working fine with its stock 64bit Windows Store apps. – Silver Falcon Aug 29 '14 at 18:18
  • I'm not saying that I don't believe you. It's just that accurate error descriptions are necessary for problem-solving. – Daniel B Aug 29 '14 at 19:25
0

YOU WILL NEVER FIND "SOFTWARE ONLY"!!!!
Go to HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\DirectDraw and look for "EmulationOnly" Change THAT value to "0". This worked for me. Endless tears of joy :):)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.