3

I just bought a new HP laptop 15-d035dx and it has a pre-installed of Windows 8.1 in it. My problem is I cannot connect it to my home's wifi router. All the devices such as ipad, iphone, samsung s3 and my old dell laptop (running Windows 7 home) are connecting to the wifi router without problems but for this new laptop (running windows 8.1) cannot connect to the wifi. It is able to see my wifi network's name but when I click to connect to it, it will ask for the key and show this message "checking network requirements", after waiting for a few seconds, it will show "can't connect to this network".

In my wifi router, my security settings is wpa2(aes) with a key. When I set the wifi router's encryption (no security settings or key) to none, then this new laptop will connect without problems. The strange thing is why does this laptop won't connect if I set the settings to wpa2 (aes) with a key.

Any suggestions, ideas, recommendations? As I am running out of ideas. Is this a problem with Windows 8.1. Any laptop should be able to connect to any wifi hotspot as long as the password is correct regardless of the settings as this will be more convenient, right?

  • I was able to make it connect to my wifi router now. I just went to the network and sharing center and click set up a new connection or network, choosing "manually connect to a wireless network", the network name should be exactly the same as the wifi router's name, choosing the correct security type and input the security key and save it. After doing this, When I click connect to the wifi, it will connect without problems. – Sam Cua Aug 29 '14 at 21:09
  • 1
    I'm just wondering, if I go to a friend's house or a coffee shop, and there is a wifi hotspot, I need to create a new network profile with the same name of the router? Isn't this very troublesome? Before, with Windows XP or Windows 7, I just need to connect to a wifi hotspot and it will connect without problems without the need to manually create a wireless connection profile. – Sam Cua Aug 29 '14 at 21:12
  • Same weird issue happening for me for my HP g6-2313AX Machine with Win8.1 and Ubuntu Dual boot. The same issue is there for both OS. So I don't think it's a problem related to OS. Still, no idea how to fix it. – Ajay Varghese Oct 21 '19 at 10:07

Browse other questions tagged or ask your own question.