0

I have a large number of music files on my hard drive, and am trying to transfer them onto a 32 gigabyte (31.2 usable) micro SDHC card so I can listen to them using my cellular phone; the transfer always fails.

I'm running Windows 8 - Core X86-64, and my laptop has an SDHC card reader so I'm using a SDHC to micro SDHC adapter. The data totals: 2,126 Files, 250 Folders, and 25.0 GB (26,871,421,564 bytes). The music is mostly m4a (aac), a large amount is m4a (alac), and there are a few mp3s.

If I just use copy/paste in Windows Explorer then it gets a decent amount done, then claims the rest are corrupt, and can't be read, they aren't. I have manually checked some of the files in question, and they are not corrupt. I can copy and paste the data successfully to my external hard drive. I'm using NTFS on my hard drive and FAT32 on the micro SDHC card so I thought perhaps it might be a filesystem problem like max file/dirs so I formatted the card as exFAT and tried again with the same result.

If I copy the data using my preferred method, Synkron Portable it claims to successfully complete, but in actuality it only copies about a 3rd which it claims uses 25 gigabytes of space anyway. If I attempt a secondary copy to add the missing files the the drive runs out of room part way through; GRRRRRRRR!

I've been using an allocation size of 64 kilobytes, but I've also tried 32, default, and some other small ones. I know the adapter isn't the problem because I've tried another one. I know the card isn't the problem because I've tried another one. I know the data isn't corrupt because Synkron and Windows Explorer can copy it to other locations, and it also plays fine in iTunes and VLC. I know the filesystem isn't the problem because using exFAT instead yielded the same results. I know that I'm getting sick and tired of transferring the same data over and over without success in a senario that should have worked 100% of the time.

If you have any ideas (no matter how far fetched) please share them; I'm at my wit's end. :(

EDIT:

It has been suggested that the problem might be a fake card that reports inaccurate storage capacity. To see if this was true I used DD on a Lubuntu live cd to try and fill the card to reveal an approximation of it's true capacity. As you can see from the DD output below the card doesn't appear to be a fake:

lubuntu@lubuntu:~$ sudo dd if=/dev/zero of=/dev/sdb bs=4MB
dd: writing ‘/dev/sdb’: No space left on device
8389+0 records in
8388+0 records out
33554432000 bytes (34 GB) copied, 8257.43 s, 4.1 MB/s
  • 2
    Have you ever verified the capacity of the SDHC card (by filling it successfully)? Who is the manufacturer? In theory, it is possible to create an SD card that misreports its capacity, are both cards you tried from the same manufacturer? – lzam Aug 29 '14 at 20:59
  • @lzam They are both Sandisk cards, but they were bought online. If it was a false capacity issue I don't think Windows Explorer would claim the source files as being corrupt, and I wouldn't be able to add more data after that, yet I can. Aside from your recomendation to fill it is there any other way to test for a false capacity? – Robin Hood Aug 29 '14 at 21:15
  • I've never really dealt with the issue personally, so I am not actually sure if there are any shortcuts to verifying capacity. – lzam Aug 29 '14 at 21:16
  • @lzam Well I'll try using DD to fill the card later. I really hope it's not a false capacity issue because I bought several cards. :( – Robin Hood Aug 29 '14 at 21:22
0

The card(s) are defective. I used h2testw 1.4 and the card was not flagged as fake, but some data was flagged as corrupted so h2testw says the card may be defective and I agree.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.