0

I installed fresh Windows 8.1 Professional 64-bit. When I copy file to another location, for instance from C:\ drive to external drive I get prompt where I have to click Continue to grant administrative rights to pending operation.

I get the same issue when I want to rename any file too. How to fix this? I don't want to be asked when I am copying files or renaming them.


I tried workaround it and run Explorer as Administrator but in my menu buttons are disabled:

enter image description here

Also the hard way by registry did not chang anything.

enter image description here


enter image description here

  • Where are you copying those files from? E.g. does it also occur when you copy files from your documents folder or from D:? Does it occur when you copy to a different destination ? – Hennes Aug 30 '14 at 18:47
  • @Hennes I occurs when I change name of file on external drive(USB). And it happens when I copy to a different destination. – user1825608 Aug 30 '14 at 19:02
  • try me workaround to start Explorer as admin: msfn.org/board/index.php?showtopic=144776 – magicandre1981 Aug 31 '14 at 4:58
  • @magicandre1981 Did you try it? – user1825608 Sep 1 '14 at 23:34
  • I use this workaround since I discovered it in Windows 7. – magicandre1981 Sep 2 '14 at 4:16
3

Just FYI this is not a 64-bit issue, nor a new issue with 8.1, or 8, or even 7.

Your personal account on Windows (Vista and later) usually has Administrator rights - but those rights are normally turned off. The prompt you're getting happens because what you're trying to do needs Administrator rights, and without them, you can't do what you're trying to do. In other words the problem is not really the prompt. It's that you, when acting as a normal user, don't have the permissions to do what you want to do.

This might be happening on the reading side, or on the writing side.

A frequent way in which this happens to people is if they're dealing with disks or files created under some other installation of Windows. Similarly if you formatted the external on another machine. Your account on the 8.1 machine has a different Security ID (SID) than you did on the other install. "Everyone" or "Authenticated users" (that's the name of a group) usually has read access to everything, but not to write. They keep changing the default rules from one version to the next, so it can be a bit confusing to keep track of.

If the issue is with writing to an external drive, a quick fix (if you don't need anything on it) is to reformat it in Disk Administrator. The short format will be fine. You may have to endure one more UAC prompt to do that. You should then have complete r/w permissions to the entire drive and anything you put on it.

Renaming a file is considered writing to it so the issue happens there too. If the issue is with files created under an account from some other machine, or an earlier install of Windows on the same machine, you can fix this by taking ownership of the files and directories.

Note, do not do this to system folders! And do not do this at the root folder for your system or boot drive! They're the way they are for a good reason.

  1. Right-click on a top-level folder that is causing a problem and click Properties. (For your external, or any drive other than your system or boot drive, you can do this at the level of the drive itself, too.) Then click the Security tab, then click the "Advanced" button.

  2. In the top of the screen you'll see something like "Owner: (a name) (your user name) and a "Change" hotword. (that is my new name for things that act like buttons, but are formatted like links.) Click it.

  3. Where it asks "Enter the object name to select", enter your user name. If it's a Microsoft account, enter the email address, otherwise just the name. Click "Check names". If it's valid it will likely change to something like machinename\username if it's not a Microsoft account. That's fine. Click OK.

  4. You're back at the "Advanced security settings" dialog. Nothing has really changed yet. You wil see a check-box, "Replace owner on subcontainers and objects". Click that. Then click "Apply". "Ok" through the "windows Security" information box that appears.

  5. If it's a big folder this will take a while.

This should do it. You are now the "owner" of the folder and everything under it, and "owner" always has full access to an object even if you don't appear in the permissions list.

If this doesn't fix it, please report back and I'll give instructions for posting the next level of information that will be needed to troubleshoot.

A whole bunch more on taking ownership - with screen shots for the GUI methods: http://www.eightforums.com/tutorials/2808-take-ownership-file-folder-drive-registry-key-windows-8-a.html Not exactly what I wrote above, but functionally equivalent.

And on permissions in general: http://www.eightforums.com/tutorials/2815-permissions-allow-deny-access-users-groups-windows-8-a.html

  • But the C:\ drive is a problem. I can't even create anything there by rightclick->new->(only Folder is available). – user1825608 Sep 2 '14 at 14:22
  • I have done those 5 steps for external drive. Now I can copy into any subfolder inside that external drive but NOT for the top level view of this drive. Also I can't create anything but folder inside. Please look at screen at the bottom of orignal post. – user1825608 Sep 2 '14 at 14:59
  • Did you do the five steps for the drive itself? i.e. right-click on the drive letter (in Explorer's left pane), Properties, Security, Advanced... what do you see there? – Jamie Hanrahan Sep 2 '14 at 19:43
-2

Tha"s the UAC kicking in.
You can disble UAC by following these instructions.

Be aware tho that UAC was implemented in Windows for preventing unauthorized changes to your computer.
More information about the UAC you can find on Microsofts' webpage

  • 1
    Turning UAC off didn't help it asks me to give administrator rights when I for example rename file on external drive. – user1825608 Aug 30 '14 at 18:54
  • Why the downvoting? Checking the UAC isn't that bad of answer. – Emphyrio Aug 31 '14 at 22:23
  • I didn't downvote, maybe it didn't help for somebody too. – user1825608 Sep 1 '14 at 23:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.