1

As mentioned here and here, bootrec.exe and bcdedit.exe have trouble functioning from a usb-booted WinPE environment. They tend to see the wrong sets of files and they also tend to break things (which I found out the hard way). As of yet, I have found no way to get them to see any file set other than that from which they were booted, IE not the WinPE environment. Booted from an actual disk, they work fine. It seems to be an issue with usb drivers in windows PE & RE from what little I was able to find. I have also tried gandalf50's (awesome) PE4 disk (found at http://windowsmatters.com/2014/05/15/standalone-win8-1update_pe-x64-or-x86-2/) with the same results.

I am a technician, though I still view myself as a novice. But I have built my own PE disks in the past and its not difficult at all. Why then does it seem impossible to get the functionality of these very necessary repair tools when the PE is booted via usb? I have found nowhere that describes a fix or any success stories or even anyone who has even attempted to get this to work. Personally, I run all my bootable tools from a single 250gb usb drive (setup with winsetupfromusb) and I greatly enjoy not being tethered to a CD/DVD binder anymore. Any help or knowledge on this matter would be greatly appreciated!

Edit: The bcdedit export operation fails. windows vista not booting The last post here contains a plausible fix. However, it requires that EasyBCD's iso caching method be used. I could re-do my huge drive with approx 30 bootable tools and this would work but its really a workaround in my mind. A creative solution regardless.

  • The question is certainly fine, though I removed the pre-emptive rant and fixed up your formatting a tiny bit (Use either a blank line or a doublespace fpr a new line) – Journeyman Geek Aug 31 '14 at 7:41
  • Thanks...I just get so tired of seeing bad answers to legitimate questions, I felt that a disclaimer/short rant was in order lol. It was late (early) when I posted this and I couldn't figure out why my paragraph formatting wasn't showing up, so thanks for clearing that up for me. – Ben Bryan Aug 31 '14 at 19:38
  • np. When you do find an answer that completely works, feel free to self answer. In addition, with your last edit, other than the selected answer other answers are in random order, so linking directly to the answer, and/or mentioning whose is it would be a great idea. – Journeyman Geek Sep 1 '14 at 1:42
0

This has been driving me crazy not having these in WinPE, not sure if this is published elsewhere but this is what seemed to work for me:

  1. Make sure you have a Windows Recovery/Installer CD that's the same bitness (x86/x64) as your WinPE image. If you don't, run the Windows Installer Creator to create a USB installer (I had to do this since my WinPE is x86).
  2. Once you have the USB installer, look for sources\boot.wim. Copy this file somewhere, and then mount it with dism to view the contents:

    dism.exe /mount-wim /wimfile:c:\path\to\boot.wim /mountdir:c:\mount /index:1
    
  3. Next, find sources\boot.wim on your WinPE drive, and copy that to a different location, and mount it to a separate directory with dism:

    dism.exe /mount-wim /wimfile:c:\path\to\winpe\boot.wim /mountdir:c:\mount-winpe /index:1
    
  4. With both images mounted, copy these files/folders from the installer mount path (c:\mount) to the mount path for WinPE (c:\mount-winpe). The paths in WinSxs may look slightly differently, depending on what build of Windows you're running:

    • Windows\system32\bootrec.exe
    • Windows\system32\en-US\bootrec.exe.mui
    • Windows\WinSxS\x86_microsoft-windows-winre-tools.resources_31bf3856ad364e35_10.0.17763.1_en-us_150e215b68bd79cc
    • Windows\WinSxS\x86_microsoft-windows-winre-tools_31bf3856ad364e35_10.0.17763.1_none_5ea4ec160fde2af5
  5. Commit the WinPE image with: dism.exe /unmount-wim /mountdir:c:\mount-winpe /commit

  6. Finally, copy the boot.wim back into the sources\ folder on the WinPE drive, then boot into WinPE and test that it's working with bootrec /? and bootrec /scanos.

  • I'm not sure messing with WinSxS is a good idea. Do you need those folders in place to get it working? – Pres May 22 '19 at 10:23
  • Yeah, it's definitely hacky. If I remember right I think I did, but since it's been a while I'd have to test again. I may have gone overboard searching for anything with bootrec in the name. – 4oo4 May 22 '19 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.