0

Some thing hs happened to my fedora 20 64 bit installaion. I can boot grub and it goes though the start up and then displays the following mesage;

Booting Fedora (3.15.8-200.fc20.x86_64) 20 (Heisenbug) [ 1.874739] usbhid 3-3.3:1.1: couldn't find an input interrrupt endpoint _

At this point the computer just hangs.

Tried using the other two kernels on the machine but get the same message. Normally it booots to Gnome so I can sign in. At present I can not even get a text log in be it root or the user.

I can boot to "rescue" but do not know enought to be able to find my way around to; a determine what is wrong and b how to fix it.

If I boot and hit "esc" just after the list of kernals everything as OK till it gets to; [ok} Start login service The just stops with a blinking cursor

Is there a way I can use a bootable DVD to refresh the installation with out loosing what is in the /home folder?

Any ideas as to how to get this upo again would be appreciated.

Thanks in advance

T

  • You can probably use a livecd to copy the contents of /home , reinstall and copy it back. Were there any changes to the system before things went bad? – Journeyman Geek Aug 31 '14 at 6:45
  • You can remove the quite option in the kernel parameters and see if you get a more verbose error message. In grub press E to edit the command, move to the kernel line and press e again to edit it, then locate the work quick and delete it, then press ctrl+x to start the boot process. – Rabin Aug 31 '14 at 6:51
0

usbhid manages all communications between you and the computer (hid = human interface device) like mouse, keyboard, webcam, touch device, etc. Something is causing a problem there.

Suggested course of action:

  • Pull any devices you don't need from your computer (keep keyboard and mouse in place), remove usb bridges, usb extenders etc and plug any usb device you really need directly to your computer
  • See if Linux boots. If it does, do a 'sudo yum update && sudo yum upgrade'. If it doesn't boot, do the same but then in rescue mode.
  • Check /var/log/boot.log and /var/log/messages for any info on what went wrong. If there is anything, try to Google the message and see if anyone ran into the same/similar problems. You can do this if the system boots normally or if it doesn't in rescue mode.
  • Plug the usb devices one by one back in while Linux is running and monitor /var/log/messages and dmesg. Try to get your usb devices working one by one. Install any specific drivers manually if you need to (Google product name/number and "linux driver")

Of course you can always do a re-install from live/install cd/dvd/usb. Just boot directly to the live/install medium. When you re-install: try to disconnect as many usb devices you don't need during install.

| improve this answer | |
  • Its Red Hat based, so you use yum, so its yum update and yum upgrade – Journeyman Geek Aug 31 '14 at 6:44
  • I have tried pulling all the USB devices off the system Keyboard, mouse and extention usb to the front panel. rebooted and get a message on the screen;Booting Fedora (3.15.8-200.fc20.x86_64) 20 (Heisenbug) and then nothing. – GRS Aug 31 '14 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.