1

I recently moved my old Thunderbird mail profile to a new Windows 8 Installed PC.

I have a Global Inbox where all my new mail gets saved. I have about 10 email accounts, and all work perfectly, all of these 10 also were present on the old computer with Windows 8 installed.

I've added a new email account, and when receiving mail via POP using the new email account, I receive the following error: Unable to write the email to the mailbox. Make sure the file system allows you write privileges, and you have enough disk space to copy the mailbox.

I've tried the following without any luck:

  • I tried to remove the Inbox.msf file,
  • Tried running thunderbird AS ADMINISTRATOIR
  • Recreated Email Account
  • Resetup Profile
  • Removed all Read Only properties to all files.
  • Changed ownership of the files
  • Made sure that the current user has Write Priveledges and nothing

When I create a separate inbox for the newly created account, the mails download

Any ideas?

UPDATE:

Below are the steps I performed untill the point I received the error message described above:

  1. I moved my whole Thunderbird profile from old pc to new pc to directory c:\My Files\Thunderbird
  2. Then I installed the latest version of thunderbird V 31
  3. Created a new Thunderbird profile using the thunderbird profile manager: Thunderbird -profilemanager
  4. Gave my profile a unique name and pointed it to read the old profile in c:\My Files\Thundebird\Profiles\9dybzaqy.default
  5. All my email address are using a Global Inbox, meaning that all mails arrive in the same inbox
  6. All worked well, sending and receiving emails perfectly for the email accounts I carried over from the old PC to the new PC.
  7. I proceeeded to add an addtional email account and set it to use it's own inbox, perfectly can send and receive mails using a dedicated inbox for this mail account.
  8. Now I need this mail account to utilize the Global inbox, meaning that the new mails send to the new email account arrive in the dedidcated email inbox that all other accounts use. And this produces the error message Unable to write the email to the mailbox. Make sure the file system allows you write privileges, and you have enough disk space to copy the mailbox. when receiving mails from the newly created email account, although all other email addresses mails get stored just fine, except for this one, I deleted all mails in the new account and send test mails and the same error appears.
15
  • 1
    So how big, exactly, is your mailbox file now? – Daniel B Sep 4 '14 at 20:47
  • Try safe mode with networking in Windows and safe mode in Thunderbird and see if either of them helps, then return to normal mode. Try also disabling the antivirus. – harrymc Sep 5 '14 at 5:53
  • @DanielB - It's quite big, but even when I clean the Inbox by deleting the physical inbox mbox file and recreate, still has the same problem – Elitmiar Sep 5 '14 at 7:18
  • @harrymc -Safe mode does not make a difference, – Elitmiar Sep 5 '14 at 7:55
  • 1
    Have you compacted the Global Inbox? You probably have Windows Defender already installed. Is TB/Options/Security/Anti-Virus checked? It makes TB write the message to a temporary file where it may not have the permissions. If that's the case, I suggest creating a C:\Temp folder with permissions for at least the Administrators and Users accounts, then setting it in Control Panel/System/Environment Variables as the value for TEMP and TMP in both sections. – harrymc Sep 5 '14 at 10:13
3

I've found the problem after some hard debugging:

On my previous installation of Thunderbird the default mail store was Maildir for some or other reason, and the new installation was default set to mbox, so when creating a new account it was set to mbox, and if the whole global inbox in maildir then it cant store mails as mbox which then bombed out. By setting the default mail store to maildir on the new installation, then all started to work.

Thanks for all the comments which helped a lot to solve the problem

2
  • 2
    Wow. Good catch, and great for documenting it for future visitors. – user Sep 8 '14 at 7:14
  • @MichaelKjörling - I hope this post could save others save some time in future – Elitmiar Sep 8 '14 at 7:24
-1

For me the issue was that the previous versions of thunderbird used an inbox with the name inbox lower case and the new version requires that it be Inbox. Thunderbirds code is badly designed and does not take case into account in a consistent manner, before I could use Local Folders/Inbox the file itself had to have the EXACT same case, even though it shows the emails from the file regardless of the files case.

2
  • What OS was this on?  Windows or Unix/Linux? – G-Man Says 'Reinstate Monica' Jun 7 '15 at 17:14
  • Linux, however I started using Thunderbird on Windows several years ago, so that is the OS the files originated from originally. – DSWFB Jun 13 '15 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.