I feel real stupid about this one.

Before I go any further I would like to state that I have a registry backup I created two hours prior to this and I should have system restore checkpoints all over the place.

Recently I had somehow corrupted SolidWorks and I was manually uninstalling all it's components, including registry components. Somehow as I was selecting the SolidWorks registry folder in WoW6432Node I ended up selecting the parent directory and sort of deleting (almost) all it's contents...

After this I could not run the registry backup I made (with CCleaner so I'm not 100% sure how complete it was), mainly due to the fact that the file hierarchy of windows is now completely screwed. I also couldn't run system restore, and so I decided to try running using a System Repair Disk I prepared on my laptop.

Sadly this process required me shutting off my, and my luck has gone ever since. First I receive a message saying "Cannot find Recovery Partition". Next, when it tried to run system repair it couldn't find C:.

One (possibly useful) thing it did was add a previous Windows install I had kept from my hdd days to the boot list.

Later when I reached a menu that let me select system restore when I tried navigating to C: all I could see was a few temporary files.

For now I've booted into the old hdd OS. I can explore the my primary boot drive but the question is how can I repair the OS? Is there anyway I can restore that registry while I'm on a different OS. Can I initiate a system restore for that partition from this OS; I certainly haven't had much luck when I've tried to run repairs from my repair disk...

I'd really like to not reinstall the main OS, and I guess I could always migrate my hdd to the ssd, but I'd like to exhaust all the possibilities first.

EDIT: As an update, so far I have found my recent System Restores for the primary drive as options options on my hdd OS System REstore.

  • I still don't have a full grasp on registries but one of my ideas was using Recuva from Piriform to try and restore any files that were deleted thanks to my edits, but I get the feeling that the SysWoW64 folder and registry entries are loosely related and this wouldnt help at all. – user507974 Aug 31 '14 at 11:08

So after speaking with several people on SE Chat, the solution was relatively simple:

I booted from my other OS and manually restored my registry located in C:\Windows\System32\config and the backup folder in that directory. The CCleaner backup I had is only minimal and would restore things I had already deleted using the service.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.