My problem: I installed nod32 and after that I can't edit hosts file on windows 8.1 - window appears "Access denied". Of course I've opened hosts file as administrator by notepad. I don't know where is problem or how to solve it...


1 Answer 1


Temporary workaround

If you just need to do a one-time change to your hosts file, you might briefly disable the Host-based Intrusion Protection System (HIPS) provided by the antivirus:

  1. Open NOD32, and press F5 to access the Advanced setup dialog.

  2. Navigate to the Computer > HIPS section.

  3. Uncheck the Enable HIPS option, and restart Windows to apply the changes.

  4. Apply the required changes. When done, follow steps 1-3, and enable HIPS again.

Note In case you need frequent read/write access, consider configuring a specific allow rule instead (see the links below). For troubleshooting purposes you can enable the Log all blocked operations option, which is available in the HIPS advanced settings.

Further reading

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .