1

My issue is deceivingly simple.

I have this combination in my .ahk file:

Capslock::Shift

This works. If I hold down Capslock, it doesn't activate, but it does whatever Shift has to do, which is exactly what I want.

Now, if I take it a step further:

Capslock::^+

It should work in paper, but it sends automatically Ctrl+Shift+= or Ctrl+Shift+=, instead of letting me use Capslock as Ctrl+Shift.

Any thoughts on how to bind two modifier keys into one single key?

3

You need to specify both the up and down actions. I also added the wildcard * option in case you wished to hold down another modifier key in addition to Capslock.

*Capslock::Send {Shift Down}{Control Down}
*Capslock Up::Send {Shift Up}{Control Up}
  • 1
    This is incredible, it worked! I completely misunderstand the usage of Send in the documentation examples, but this is crystal clear. Much obliged! – AeroCross Aug 31 '14 at 20:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.