All of a sudden a couple days ago, my Chrome browser (v. 37, on Win7 desktop) stopped working. It just displays the "Google Dinosaur" with the message "Unable to connect to the Internet" (Error code: DNS_PROBE_FINISHED_NO_INTERNET). However, IE and Firefox have no problems. Also, another computer on my home network has no problems with Chrome, which rules out any router issues. I have tried:

  • rebooting the computer
  • resetting Chrome (deleting all Content & Cookies; restoring all default browser settings)
  • launching Chrome with no extensions, as well as in incognito mode
  • disabling all extensions manually
  • uninstalling and re-installing Chrome
  • temporarily disabling my virus protector (Microsoft Security Essentials)
  • typing in IP addresses directly
  • Command Prompt (Run as Admin): netsh winsock reset (+ Restart)
  • Clear the host cache (in chrome://net-internals/#dns)
  • growling fiercely at the computer

Nothing helped. (Except the last one, which made me feel slightly better, but didn't resolve the issue). Any other suggestions?

UPDATE: I just realized that I can't even access my router using Chrome (typing the direct IP address), although, again, IE and FF have no problems there either.

UPDATE #2: After following the suggestion to Clear the Host Cache, the cache list began populating with several entries (all **.google.com sites) with this note in the Address field: error: -137 (ERR_NAME_RESOLUTION_FAILED) (a problem which was discussed, though not solved, recently). I assume it is all part of the same underlying problem.

UPDATE #3: As @FredsBend's link pointed out, this is a known (and apparently widespread) issue that is being tracked and investigated by the fine folks at Chromium. Star the bug at crbug.com/399968 to get notified of a fix.

  • Win+R -> netsh winsock reset -> Restart Sep 1, 2014 at 7:46
  • @crazypotato: Good idea, but it didn't help.
    – kmote
    Sep 1, 2014 at 17:55
  • 1
    Try check portable chrome for make sure its only issue with your current installed Chrome. People says help if reinstall or update wi-fi router(have you it?) driver. Sep 3, 2014 at 8:15
  • 1
    @crazypotato: your link had a good suggestion ("Clear host cache"), but unfortunately it still didn't resolve the issue.
    – kmote
    Sep 5, 2014 at 4:28
  • 1
    This is apparently common: productforums.google.com/forum/#!msg/chrome/ryQ4d-ai3zg/… I'm tending toward a windows update sending chrome down a fubar path. I recall allowing an update just before mine stopped working.
    – user287352
    Sep 5, 2014 at 21:56

4 Answers 4


The problem is related to Chrome and a black list service that is new and apparently not ready. The blacklist service (wrongly) blocks some dll's, most common being one that is used by an internet filtering software called Covenant Eyes. According to Covenant Eyes customer support, the problem only exists on versions 4.5.3 and earlier. Upgrading to version 5, which requires a full uninstall of the previous version, will fix the issue.

There is a workaround that involves a simple registry edit. This is useful if you cannot upgrade Covenant Eyes for some reason or your issue is related to the Chrome blacklist service, but not Covenant Eyes.

Change registry value HKEY_CURRENT_USER\Software\Google\Chrome\BLBeacon\state from 1 to 0.

The registry edit workaround has mixed reviews on this page. Some say it works, but reverts back after closing Chrome. Others report that it works perfectly and they can close Chrome and it will not revert. The reason is not clear, but most with the Covenant Eyes issue are reporting that it is working perfectly for them. A few users without the Covenant Eyes issue have reported that the registry edit worked for them as well.

  1. I have personally tried the Regedit option and it worked and has not reverted after two opens and closes of Chrome. I have not tried upgrading Covenant Eyes. I will try that on a different computer without making the registry edit and report back.
  2. How to use the registry editor. Be cautious when using the registry editor. If you don't know what you are doing you can really mess up your computer.
  • On Sep. 24th, I had to redo the regedit option for the first time, but on all my computers. Chrome must have had a minor background update that switched the registry value back to 1. I still have not upgraded Covenant Eyes.
    – user287352
    Sep 26, 2014 at 17:46
  • 1
    The powershell version of this Set-ItemProperty HKCU:\Software\Google\Chrome\BLBeacon\ -Name state -Value "0" Nov 27, 2014 at 19:21
  • It is now January, I have still not upgraded Covenant Eyes. I've not had any problems since.
    – user287352
    Jan 9, 2015 at 23:49
  • Almost a year later and I've switched to FireFox for other reasons. Chrome does still seem to work, when I do use it, however. Covenant Eyes is not updated still.
    – user287352
    Jul 28, 2015 at 3:27
  • I've now switched back to Chrome and Covenant Eyes version 4.5.3 has not given me any problems. Chrome: Version 48.0.2564.97 m (64-bit) Windows 7
    – user287352
    Feb 2, 2016 at 18:50

The following link provides a workaround. Basically you run RegEdit from cmd and change HKEY_CURRENT_USER\Software\Google\Chrome\BLBeacon\status from 1 to 0.

After this you can close / open Chrome and it will keep working.

  • 8+ years on and that solution doesn't work any more. Aug 10 at 15:45

You could try launching chrome in safe/no extensions/unsafe or some other mode (I know there are some options but dont remember which). Try connecting to a site typing ip address directly http://n.n.n.n ... maybe an issue with chrome using different dns path thanother browsers.

  • Not sure how to launch in any non-standard mode (except incognito, which didn't work either). I typed the IP address of Google (; no joy.
    – kmote
    Aug 31, 2014 at 22:35
  • I figured out how to launch Chrome with no extensions. Still dead.
    – kmote
    Aug 31, 2014 at 22:42

I found a solution in my case. My issue seems to be related Bitdefender anti-virus. When Bitdefender was in "Game mode" I could not connect to any site using Chrome. I turned "Game mode" off and restarted Chrome. This worked for me, even after turning "Game mode" back on. Let's see how long this solution lasts.

Not the answer you're looking for? Browse other questions tagged .