0

I have problem with Firefox(31.0) on my Windows(7). I don't want that Firefox use system proxy, and for this issue, set "No proxy" in Options/Advanced/Network/Settings. But when I close Firefox then open it, this option changed to "Use system proxy".
I do this config in "about:config" manually.(set '0' in network.proxy.type) But similarly when Firefox restarted, this value changed to '5'.

How can i set permanent config for this ?

  • 1
    This shouldn't happen. Is this machine under your control or is it part of a corporate network? – Paul Sep 1 '14 at 5:59
  • Unfortunately This happens and cause of confusing. My PC is connected to network, but is not under control somethings like domain. – M-Razavi Sep 1 '14 at 6:15
  • Have you had any trouble with viruses recently? Some set the pref.js file to read only, or it can be corrupted. Have a look at the properties of C:\users\[userid]\appdata\roaming\mozilla\firefox\profiles\xxxxx.default\prefs.js and see if it is read-only (after closing firefox) – Paul Sep 1 '14 at 6:43
  • 1
    Disable all addons and plugins. If dont work try create new user. – crazypotato Sep 1 '14 at 6:53
0

I found that "Janus Proxy Configurator" make this crazy behavior. when i disable it, Firefox works well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.