When I try to authorize my iTunes account on Snow Leopard (10.6) with iTunes 9.0.2 I get this error:

"There was an error storing your authorization information on this computer the required file was not found or has a permissions error. Correct..."

And if I try to download something from the iTunes store, I get this:

iTunes couldn't download your purchase.You don't have write access for your iTunes Media folder or a folder within it...."



Inside "/Users/cbrulak/Music/iTunes":

-rw-r--r--@ 1 cbrulak  staff   3211  8 Dec 14:05 iTunes Library
-rw-r--r--  1 cbrulak  staff  12288  8 Dec 14:05 iTunes Library Extras.itdb
-rw-r--r--  1 cbrulak  staff  32768  8 Dec 13:48 iTunes Library Genius.itdb
drwxr-xr-x  4 cbrulak  staff    136  8 Dec 13:48 iTunes Media
-rw-r--r--@ 1 cbrulak  staff  14040  8 Dec 13:49 iTunes Music Library.xml
-rw-r--r--@ 1 cbrulak  staff      8  8 Dec 14:05 sentinel

Inside /Users/cbrulak/Music:

drwxr-xr-x  8 cbrulak  staff  272  8 Dec 14:05 iTunes

Any ideas?

Open up Disk Utility (in /Applications/Utilities/ ) and click on your drive and then run Repair Disk Permissions.

If that doesn't work open up Terminal (also in Utilities) and type:

ls -l

then hit return, and paste the result here.

  • did that, really messy output in the comment window, will edit the question to get some formating – cbrulak Dec 8 '09 at 21:08
  • Don't bother. It was to see the permissions on the iTunes folder but if you deleted it there is nothing to see. – ridogi Dec 8 '09 at 21:13
  • this is after I re-isntall the app. – cbrulak Dec 8 '09 at 21:18

Okay, I have more information. I bought a new iMac and moved everything over to the new machine. But I couldn't authorize or deauthorize the new computer. /Users/Shared existed and had the correct permission bits, so that wasn't the problem. Here's how I fixed it.

In /Users/Shared there is a directory named 'SC Info' (without the quotes, obviously). This was left over from the system move, but was not properly configured and contained files that were now bogus (uid was wrong, etc.).

The fix is just to remove the 'SC Info' directory. When I then tried to listen to music I had purchased, it asked me to authorize the machine and it let me!

I had a similar problem.

First check the permissions for the iTunes application:

ls -l /Applications/ | grep 'iTunes'

You will find iTunes owner is root and is in the wheel group. Check /Users/Shared - it will have the same permission.

I found I had deleted /Users/Shared when I removed StarCraft 2.

Entering the following commands fixed this and iTunes worked again:

sudo chown -R myusername:staff iTunes.app
sudo mkdir /Users/Shared
sudo chown -R myusername:staff /Users/Shared
up vote 0 down vote accepted

I changed the group owner to be "admin" instead of "wheel".

Despite the fact that the Apple KB says that the group owner should be 'wheel'.

  • The answer does not mention which file or directory this applies to. – avernet Jul 13 '10 at 5:49
  • look at the "Edited" part of the question. All those files. – cbrulak Jul 29 '10 at 6:25

I just had the same problem, tried these solutions and others I found around the internet. No luck. Until I downloaded some freeware called FGPermission - available for download here:


I selected my Music folder just to make sure all my permissions were read, write and execute. All were for the owner, which I thought would mean all would be fine, but iTunes still wouldn't let me import a CD. I checked the boxes to add read, write and execute permissions for group, and now I'm importing the CD. I don't fully understand it, but so be it. This thing worked. Good luck!

I had a similar problem with the same error message. I found this:


In summary, run the following command and it will be fixed:

sudo rm -rf /Users/Shared/SC Info

protected by studiohack May 29 '11 at 3:22

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.