2

Recently I installed Synergy on my desktop PC (running Windows 8.1) and my Raspberry Pi (running Raspbian) so the PC's keyboard and mouse is shared with the Raspberry Pi. The Windows PC is a Synergy server and the Pi is a client, and both run Synergy 1.5.1.

Everything works fine apart from both Shift keys not working on the Pi. It's not a major problem as I can work around it by using Caps Lock or by copying & pasting characters requiring the Shift key from the Windows PC, but it is annoying.

People have had similar issues with just the right Shift key not working and fixed it by mapping the left Shift key to the right one, but in my case neither Shift key works so I can't do that.

Some people also found that downgrading the Synergy server to 1.3.4 fixes the problem with the right Shift key not working, but I'm not sure if that will fix this (also that worked on Windows 7, but I'm running 8).

I was wondering if anyone has the same issue and if there are any fixes or workarounds?

2

http://synergy-project.org/spit/issues/details/4125/ Uninstall Windows Updates KB2975719, KB2982791, and KB2993651 and reboot. Synergy dev will probably fix it in the next update.

  • Thanks, just had a look at that webpage, I'm just worried that removing those security updates could leave a vulnerability in my computer, is it safe to remove them? – Ruben9922 Sep 4 '14 at 18:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.