7

When I launched Chrome (37.0.2062.102) today, all my extensions were gone, although yesterday everything was fine. I did some research into this issues of course, assuming that my user data is corrupt. One "solution" was to delete "%LOCALAPPDATA%/Google/Chrome/User Data/Default" which was what I did, knowing that I synced my browser state anyway.

I use the sync feature for all my Chrome instances since it is available and it worked flawlessly over the years. However, now the "Sign in to Chrome" menu entry is simply missing. I found out that you can sign in via some kind of new profile manager, I never saw before, but then you are not prompted for your sync passphrase and neither extensions nor stored passwords are restored.

When you google for a solution to this, you'll find forum entries and posts from all years for all Chrome versions. Everything outdated and nothing on this specific issue for the most recent Chrome version. Even when you look into Chrome's official help pages, you are always told to use the "Sign in to chrome" menu entry, which obviously isn't possible anymore.

So please, can anyone tell me how I am supposed to sign in and get my broken Chrome instance syncing again?

2
  • Did you try to uninstall and re-install?
    – jsejcksn
    Sep 2, 2014 at 8:33
  • Yep. Been there, done that. Sep 2, 2014 at 11:22

2 Answers 2

9

I found the solution to my problem, by stumbling upon

chrome://policy

where SigninAllowed was flagged false and SyncDisabled was flagged true

These two flags can be set via the following registry keys:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\SigninAllowed HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\SyncDisabled

Just for reference.

5
  • The reason why these values changed from one day to the other, is still something I have to find out. Probably the Admins are enforcing new policies without prior warning. Sep 2, 2014 at 11:34
  • 1
    Stackexchange forces you to wait 2 days before you are able to accept you own answer. Still one hour left ;) Sep 4, 2014 at 7:18
  • I suspect when Chrome is installed on Windows without Admin privileges (and defaults the install the to user directory), these flags get set to disabled. Anytime I've installed as an Admin I haven't had this issue.
    – Adam
    Jan 5, 2015 at 16:46
  • 1
    This is probably because an admin is enforcing these settings with a GPO or something. These settings are located in 2 location, one for the currently logged in user, and one for the whole environment. I created a REG file containing both situations, for both HKCU and HKLM. But please be aware that they could be deleted at login or when the policy is updated, so you will have to re-apply them. I created a scheduled task running every other hour to automatically import these settings. PS: I am the sysadmin applying the GPO :D
    – noname
    Jul 14, 2016 at 9:36
  • Yes. That was the case. I switched to chromium portable as a consequence ;) Jul 14, 2016 at 10:22
6

The registry keys that I found to control this were

HKEY_CURRENT_USER\Software\Policies\Google\Chrome\SigninAllowed
HKEY_CURRENT_USER\Software\Policies\Google\Chrome\SyncDisabled

rather than

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\SigninAllowed
HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Google\Chrome\SyncDisabled

I had to run regedt32 as an administrator to update the settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .