3

When opening messages in Outlook 2010 (not using the reading pane) you can hold control down and roll your mouse wheel up to zoom in on the message, but you have to do this each time you open a message.

Is there a way to set the default zoom level for messages? For example, set the zoom level to default to 150% for each message.

Failing that is there any other way I can make the default text to larger when reading messages? (without changing the DPI settings in the OS)

2 Answers 2

3

This is normal behavior for Outlook 2010; it does not retain zoom adjustments. The only option you have is to create a macro that runs at launch or to use an Add-In for zoom control.

Here is how to add VBA to set the zoom level at application start-up.

  1. Set your macro security to Low.
  2. Open the VB editor using Alt+F11
  3. Expand Project1 to show ThisOutlookSession
  4. Paste the macro in ThisOutlooksession
  5. Set a reference to Microsoft Word in Tools, References
  6. Click in the Application_Startup macro and press the Run button to kick start it without restarting Outlook.

Option Explicit
Dim WithEvents objInspectors As Outlook.Inspectors
Dim WithEvents objOpenInspector As Outlook.Inspector
Dim WithEvents objMailItem As Outlook.MailItem

Private Sub Application_Startup()
Set objInspectors = Application.Inspectors
End Sub

Private Sub Application_Quit()
Set objOpenInspector = Nothing
Set objInspectors = Nothing
Set objMailItem = Nothing
End Sub

Private Sub objInspectors_NewInspector(ByVal Inspector As Inspector)
If Inspector.CurrentItem.Class = olMail Then
Set objMailItem = Inspector.CurrentItem
Set objOpenInspector = Inspector
End If
End Sub

Private Sub objOpenInspector_Close()
Set objMailItem = Nothing
End Sub

Private Sub objOpenInspector_Activate() 
Dim wdDoc As Word.Document
Set wdDoc = objOpenInspector.WordEditor
wdDoc.Windows(1).Panes(1).View.Zoom.Percentage = 150
End Sub

Note: The second to last line is where you set the zoom percentage. Change the 150 to the percent you desire.

Source - Adjusting Outlook's Zoom setting in Email

5
  • For a few weeks this worked, but now the zoom is gone again. If I try to re-enter the macro, it is already there. Something else broke the fix.
    – userJT
    Dec 5, 2014 at 7:14
  • An Office or Windows update may have changed something. Check your security settings. See if you can run the macro manually (press Alt+F8 to get to the macro menu). There isn't much more help I can give you. :-\
    – CharlieRB
    Dec 5, 2014 at 12:03
  • You can then self sign your macro by running selfcert.exe, installing the certificate at the trusted root certification - local computer, reopening outlook and chosing always trust this publisher (or if it doesn't pop up on outlook initial load manually press alt-f11 and then choose always trust this publisher).
    – BornToCode
    Feb 6, 2017 at 8:04
  • @CharlieRB this doesnt work with 2013
    – Zombo
    Sep 24, 2018 at 14:55
  • I'm not suprized. It was written in 2014 specific to Outlook 2010 version. If you can't find an answer, you may need to post your own question.
    – CharlieRB
    Oct 5, 2018 at 11:24
0

I found an addin called ZoomIn which adds a button to the ribbon to save the zoom for all the messages that you open (You can also change it whenever you want to). The only downside is that it is a paid tool.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.