0

I'm trying to install the framework 3.5, but I always get an error:

  • First I tried to add through "enable Windows features", but I got this error:

enter image description here

  • Then I tried to execute this command in the console:

dism.exe /online /enable-feature /featurename:NetFX3 /All /Source:j:sources\sxs /LimitAccess

I obtained another error:

enter image description here

If you need translation for the images please ask me.

  • 1
    Error 0x800f0906 seems to be self-explained, isn't it: “Windows couldn't connect to the Internet to download necessary files. Make sure that you're connected to the Internet, and click Retry to try again.” – duDE Sep 2 '14 at 13:27
  • You will need to translate the error messages since this is a primarly an English website. – Ramhound Sep 2 '14 at 14:58
  • Forgot to say I have internet – Carlos Corral Carvajal Sep 3 '14 at 6:05
3

Remove the Updates KB2966826 and KB2966828, reboot and try to activate .Net 3.5 again. Both are .Net 3.5 updates and they block the setup. Microsoft is aware of the issue and tries to fix it.

If you have any addition MUI packs installed you need the DVDs of the additional language, copy the SxS folder of both DVDs to a local folder and point with the /source parameter of DISM to this folder. I wrote this last year to Microsoft but they still haven't updated the documentation.

  • I've exactly the same problem BUT i don't have any of these updates installed (fresh windows 8.1 install). Any other ideas ? – MartinB Sep 2 '14 at 17:17
  • @MartinB do you have any additional MUI (language) installed? – magicandre1981 Sep 3 '14 at 4:16
  • No additional languages but I found a way to bypass they error. See my answer below. – MartinB Sep 4 '14 at 12:21
  • I didn't have either update KB2966826 or KB2966828 installed . Luckily, Microsoft created a patch that allows .net 3.5 to install properly. Just scroll down here and download the version for your OS support.microsoft.com/en-us/kb/3005628 – Joseph Yancey Aug 12 '15 at 13:43
0

I had the same problem (error 0x800f081f on the dism command) and after trying many things, I figured out that the message was right : even if I was running the command line as an administrator, I got an error accessing the directory on the the mounted drive (x:\sources\sxs in my case) but I was able to see it in Windows Explorer without any problem. So I fixed the problem simply by copying the sxs directory to c:\temp and rerunning the dism command. Worked perfectly.

It still a mystery for me why I can't access the x drive from command line (even as administrator). If you have any idea, I'm curious what could be the reason.

Thanks.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.