I am trying to install .NET 3.5 to work on few legacy applications and this has been burning my head for past few weeks.

  1. During installation a pop up window requests me to install .NET 3.5 and when i hit download it fails stating issues with internet connection. But internet works just fine

  2. Tried enabling .NET 3.5 from Control panel it redirects to " Download from Windows update " and the download goes on forever ( best try 6 hours on 18mbps wifi keeps loading..)

  3. Using Dism with and without /LimitAccess the process gets stuck at 65.8% and then throws a component error

  4. Downloaded offline package 253 MB from microsoft when i tried to install it again asks me download 3.5 to launch dotfx35.exe which is the setup file :(

  5. Tried everything from http://support.microsoft.com/kb/2734782 no luck

Please help.. :(


Remove the Updates KB2966826 and KB2966828, reboot and try to activate .Net 3.5 again. Both are .Net 3.5 updates and they block the setup. Microsoft is aware of the issue and tries to fix it.

If you have any addition MUI packs installed you need the DVD of the additional language, copy the SxS folder of both DVDs to a local folder C:\sxs and point with the /source parameter of DISM to this folder:

DISM.exe /Online /Enable-Feature /FeatureName:NetFx3 /All /Source:C:\sxs /Limitaccess

I wrote this last year to Microsoft but they still haven't updated the documentation.

  • In case you don't find the mentioned KBs then try to run from command-line: "DISM.exe /Online /Enable-Feature /FeatureName:NetFx3 /All /Source:C:\sxs /Limitaccess" where sxs folder is copied from windows iso -> sources\sxs
    – Valentin
    Jun 19 '15 at 10:31

I found the answer, it looks like the ISO was corrupted which throws while executing dism.

The issue is now fixed. I used a working disk and verified md5.


I went through all of the troubleshooting documentation here and downloaded the \sxs here. Eventually at the prompting of magicandre1981 (above) I searched for the updates KB2966826 and KB2966828 he suggested removing. My system was up to date, but didn't have those updates. However, removing update KB2966827 fixed the issue for me. Since this was a last step I am unsure if it was necessary to download the \sxs, but it could still be a good idea in case your files have been corrupted somehow. As a final step, after successfully using the DISM.exe method on the first page I linked to, I went through the more typical process using the control panel. Under programs and features the "Turn Windows features on or off" menu includes .NET Framework 3.5. This time, instead of prompting me to download the framework it merely told me that the change had been completed successfully.

Not the answer you're looking for? Browse other questions tagged or ask your own question.