0

On my home network I recently replaced a desktop that was running Windows 7 Professional with one that is running Windows 7 Home Premium and now the other 2 PC's (Vista & XP) cannot access the shared files on ANY network device using the the Network device name, however I can access any network device using the IP address. All three computers are on the same network, all are members of the same workgroup, the Windows 7 computer does not have HOMEGROUP enabled. If I try to map a network drive using the Network device name the system asks me for a logon and then rejects it. If I do the exact same thing, only using the IP address instead of the network name it works.

All computers and shared drives are in the same workgroup. Network Discovery is turned on. File & Printer sharing is on in WIN7 File Sharing: ON Printer Sharing: OFF in Vista Public Sharing is On Password Protected Sharing is OFF

Using the the Network Name: The Windows 7 machine can see all network shares and access them - The Vista Machine cannot see any network shares - The XP machine can see the network shares of the Vista machine but not the WIN7.

Using an IP address in place of the Network name: All computers can see and access the network shares

All computers use NETBIOS for address translation.

  • Please edit your question to include more detail of what you have researched in reference to connecting Windows 7 with Vista or XP. Also, is the new Windows 7 PC using the same WORKGROUP name as the other devices? Is the network type set to Home/Work? Is Network Discovery turned on? – CharlieRB Sep 3 '14 at 12:31
1

If you do not have a DNS server running in your network, the network names will be resolved via NetBIOS.

Check if all machines have NetBIOS enabled:

  1. Click Start, and then click Network. (Or you type ncpa.cpl into the search box, and press ENTER).
  2. Click on the Network and Sharing Center, and then click Manage Network
  3. Right click on the Local Area Connection or the connection you are using, and then select
  4. Properties.
  5. Select the Internet Protocol version 4 (TCP/IPv4)
  6. Click the Advanced button under the General tab.
  7. Click the WINS tab.
  8. Click the Enable NetBIOS Over TCP/IP button.
  9. Click Ok.

quoted from http://ecross.mvps.org/howto/enable-netbios-over-tcp-ip-with-windows.htm

A restart might be requiered on the XP/Vista machine after changing that

Also check if the computer name was correctly set on the Windows 7 machine

  • Control Panel
    • System and Security
      • System
        • Computername must be set to a valid entry
  • Checked the Netbios settings and they were as you discribed. Still didn't fix the problem. – Swede Sjolund Sep 4 '14 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.