0

Until recently my laptop took at most around 5 seconds to go to sleep when the lid is closed. This was the case for several months. Recently however, my laptop takes around 2 minutes (maybe more) to go to sleep whenever the lid is closed, or when the sleep command is issued. When the sleep command is issued, the screen fades to black, and the computer becomes unusable until it goes to sleep. This happens most of the time now, but sometimes it takes 5 seconds as it used to, if I'm lucky.

This issue has suddenly started happening, and wasn't a gradual thing, so I think there's a specific thing that's causing this issue, and not just a result of slow "computer rot" or whatever.

This is pretty unacceptable to me because I would want to make sure it's sleeping before I stick it in the bag or whatever, and it also seems like a waste of time. The problem is I'm not sure when exactly this started happening, so I can't tell if it's caused by an update, or by a USB device I plugged in, or whatever.

Waking up from sleep is as fast as it was before, taking at most 2 seconds. So no issue there.

Are there any ways to identify the cause on why it is taking too long? It seems to me that Windows is waiting for a driver, service, program, or device to respond before going to sleep, so I'd like to find out what that is exactly.

If it matters, I'm running Windows 8.1 64-bit on a Sony Vaio Pro 11.

2
  • 1
    Anything relevant in the windows event viewer? – Tyson Sep 4 '14 at 5:21
  • I haven't used the event viewer much so I'm not sure what to check for this – 9a3eedi Sep 4 '14 at 12:52
3

I've followed the instructions found in this forum to determine what was causing the problem. http://www.msfn.org/board/topic/158252-trace-why-windows-8-boots-shutsdown-or-hibernates-slowly/

It mostly talks about determining what takes time for bootup, but the same instructions apply for standby. It might be hard to follow the instructions though so I will go ahead and write what I did

I first downloaded the Windows 8.1 SDK from the following link, and made sure to install the Windows Performance Toolkit (you don't need to install anything else). The following link is for Windows 8.1 (if you have Windows 8 you need to search for the right SDK for Windows 8) http://msdn.microsoft.com/en-US/windows/desktop/bg162891

After installing the toolkit, I started the command prompt with administrator privelages (just search for cmd and rightclick and start with admin privelages)

Run the following command

xbootmgr -trace standby -traceFlags BASE+CSWITCH+DRIVERS+POWER -resultPath C:\TEMP

A popup will appear and your computer will go on standby. After you're sure it went to standby, if it doesn't wake up, wake it up. Wait for the popup to disappear. The trace for the standby process will all be stored in C:\TEMP but there will be way too much information so we need to "summarize" it

In the command prompt, go to C:\TEMP, and run the following command to create a summary XML file

xperf /tti -i standby_BASE+CSWITCH+DRIVERS+POWER_1.etl -o summary_stanby.xml -a suspend

A new XML file will show up. You can open it with a text editor or Internet Explorer or whatever XML editor you want. You will see under a few XML tags representing the different suspend steps that the system take. There's a tag for apps, services, superfetch, and devices, among others. The "Duration" attribute of the tags is what you're looking for, and by going through the XML you can find out what's causing the delay. The tags are conveniently sorted by duration.

In my case, I noticed that the WiFi driver was the culprit, take up more than an entire minute and a half (!!!) to suspend. To make sure, I disabled the WiFi driver in Device Manager, and tried closing the lid. Going to standby took only 3 seconds. I then updated the WiFi driver and surely enough the laptop standby time is now around 5 seconds as expected.

EDIT: Scratch that, updating the WiFi driver didn't fix the problem (garbage drivers I guess), but the problem is definitely the WiFi driver

1

It was my memory card reader(even though it actually had no memory card inside it) that I had plugged in that was the culprit, after simply removing it sleep time returned to normal. So you might wanna check anything attached to the ports on your laptop!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.