1

I am having an issue with my NVIDIA 870M graphics card. When I play games, it caps the framerate to 30FPS when running on battery power, even playing on both high and low graphics settings.

When I switch to Intel graphics (in the Nvidia Control Panel), it runs very well on battery power, 50FPS on lowest settings (on the Intel HD Graphics), while with NVIDIA it is 30FPS. I need my high performence NVIDIA card to run at a high framerate when running on battery life. This applies to all games that run on NVIDIA.

List of games this applies too (basically all the games I have):

  • CounterStrike: GO
  • League of Legends
  • WarThunder
  • Tribes Adcend
  • Minecraft

What I have tried so far (all failed):

  • Disabling VSync

Clicking on the “Battery” icon in the tray -> more power options -> change plan settings -> Change advanced power settings -> Intel Graphics settings

Going to the “Nvidia Control Panel” and looking for powersaving options, none there.

2

See this post for an explanation as to why this is happening:

NVIDIA cards and Intel chips are all sporting power saving features these days, and your symptoms will primarily have to do with the NVIDIA card's performance level when taken off AC power. Regardless of the user's preferences, these cards will automatically drop to a lower performance level when running on battery power.

A link is included to a discussion on the issue and some registry hacks if you’re determined to change this behaviour.

| improve this answer | |
1

I fixed the problem by going into Geforce experience, and then battery boost under preferences. From there using the slider you can alter the cap on the FPS in games.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.