0

I want to install Ubuntu beside my windows 8 but I made a mistake that i installed only Ubuntu ,but when I logged in Ubuntu and went to open my partitions , an error appeared said tha

Error mounting /dev/sda5 at /media/abdo/mohamed:

Command-line `mount -t "ntfs" -o "uhelper=udisks2,nodev,nosuid,uid=1000,gid=1000,dmask=0077,fmask=0177" "/dev/sda5" "/media/abdo/mohamed"'

exited with non-zero exit status 14: The disk contains an unclean file system (0, 0). Metadata kept in Windows cache, refused to mount. Failed to mount '/dev/sda5': Operation not permitted The NTFS partition is in an unsafe state. Please resume and shutdown Windows fully (no hibernation or fast restarting), or mount the volume read-only with the 'ro' mount option"".

Please I need help here.

  • Your question is not clear the error message is pretty clear – Ramhound Sep 5 '14 at 1:20
  • my question is i need to fix this error and boot in windows beside ubuntu ?!! – Abd Elrahman Mohsen Sep 5 '14 at 1:41
  • So why can't you boot into windows all this tells me is NTFS partition was shutdown blocking Ubuntus ability to read it ( if it did in this state it would corrupt it ) – Ramhound Sep 5 '14 at 1:54
  • i can not boot to windows 8 when i start my pc it logged in ubuntu directly can you show me steps to solve this problem – Abd Elrahman Mohsen Sep 5 '14 at 3:02
  • 1
    You did backup before you installed ubuntu, right? I've never heard of ubuntu not chainloading windows before, and I'm wondering if you clobbered the wrong partition. – Journeyman Geek Sep 5 '14 at 3:34
1

I'd refer you to this AU question (found via here, which has an identical error message) and the selected answer. If you have an AU account, go upvote him, since he did all the hard work. I'm paraphrasing, and cutting it down quite a bit

Basically windows 8 does a lot of neat tricks to boot up fast, including usually partially hibernating. This results in insanely fast reboot times, but if another OS changed something, windows will probably wake up in a confusion.

As such NTFS 3G (the wonderful userspace driver for NTFS on linux) will refuse to mount if there's a hibernation file present.

Long term answer would be to turn off the hibernation file/fastboot from windows. You can also mount readonly, or tell NTFS 3g to delete the hibernation file.

I'd conclude by pointing out, that's exactly what the error message said, and that I found the answer to this via google, on one of our sister sites.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.