2

I'm running Solaris 10 1/13 (x86) on a HP EliteBook 8470p laptop. I log into the CDE desktop. Everything (audio, video and network) seems to be running ok until I logout. When I logout, the screen goes blank (the same color as the workspace background), but the login window does not re-appear. So far, the only way I've been able to recover is to reboot the laptop. Update: I learned I can "logout" if I "kill -9" my Xorg process. This returns me to the login window.

What I've tried/learned so far:

  1. The same thing happens if I log into the Java desktop.
  2. All users are affected, including root.
  3. I can still login remotely with rlogin and ssh.
  4. I can still login using remote desktop from another Solaris x86 workstation.
  5. The login window appears to be there, I just can't see it. First, I login remotely with rlogin. Next, I enter my username & password on the laptop. Then from my rlogin session, I do "ps -deaf" and I can see a list of my desktop's login processes. I just can't see anything on the screen. I can logout of the desktop (using keystrokes in the blind to find the logout). Again, I use "ps -deaf" to verify the logout worked.
  6. The ps command confirms dtlogin, dtgreet, and Xorg are still running.
0

This is not my preferred solution, but it works and allows me to continue with my real work.

I overwrote XSession_Exit in /etc/dt/appconfig/types/C/dt.dt to run a shell script. That shell script kills the Xorg belonging to the user, which returns the user to the login window. I also cutomized /etc/dt/config/Xreset to call a script to restart cde-login if Xorg doesn't restart.

This is a crude solution, but it will do for now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.