0

Arch Linux Wifi Connection Issues

I am currently in the process of trying to install Arch i686 on an Acer Aspire One 532h (32 bit).

At this point I am still in the LiveCD environment and setting up the wireless connection. However, I am running into a problem with connectivity.

I guess I should say that I have already verified the compatibility for my network adapter. Atheros AR9285 http://www.linuxquestions.org/hcl/showproduct.php/product/4446/cat/160

Also verified it from the Arch command line:

#lspci -k

02:00.0 Network controller: Qualcomm Atheros AR928X Wireless Network Adapter (PCI-Express) (rev 01)
...
Kernel driver in use: ath9k
Kernel modules: ath9k


# iw dev

says my interface is wlp2s0 (it's the only interface available)

when i try to use:

# wifi-menu

I can select my SSID and enter my password and save the profile

# ip link show wlp2s0

3: wlp2s0: <NO CARRIER, BROADCAST, MULTICAST, UP> mtu 1500.......

# dhcpcd wlp2s0

dhcpcd[2191] version 6.4.2 starting
...   [2198] wlp2s0: starting wpa_supplicant
...   [2201] wlp2s0: failed to start wpa_supplicant
Line 1144: unknown EAP method 'SIM'
...
...
dhcpcd[2520]: wlp2s0: waiting for carrier
dhcpcd[2520]: timed out
dhcpcd[2520]: exited

I also created a file at /etc/wpa_supplicant/test.conf very simple consisting of basically the SSID and password not mentioning an EAP, WPA, WEP or any protocol.

 # wpa_supplicant -B -i wlp2s0 -c <(wpa_supplicant/test.conf)

Successfully initialized wpa_supplicant

 # dhcpcd wlp2s0

(I get the same error message as earlier.)

Not sure what I can do at this point. I verified the .sig on the ISO, verified that my network card is supported. Used the simple interface (wifi-menu), used the CLI to create a .conf and execute the wpa_supplicant manually. I am getting a hangup at the dhcp somewhere but not sure where I need to look to diagnose this problem.

Any suggestions?

  • If you used wifi-menu there is no need to create your own wpa_supplicant config file. wifi-menu will handle this. Basically after you run wifi-menu wlp2s0you should have a connection. Did you start it like this? – ap0 Sep 5 '14 at 20:17
  • Of course, I am fairly basic and I chose the easy way but when that failed I started to dig deeper on my own. Is there something I can change in the DHCP setting? How could I get there? Oh, also, not sure if this has any bearing but, initially my wifi connection was hidden. After I looked at the wifi-menu GUI, I didn't see an option for this. I exited and changed my wifi setting to visible then went back to wifi-menu and selected my wifi access point. Could that cause a misconfiguration? – David Sep 5 '14 at 20:25
2

Try setting the channel mode to auto. Before you do that make sure your wifi interface is down. After that, turn it back up. Solution found here.

$ ip link set wlp2s0 down    
$ iwconfig wlp2s0 channel auto
$ ip link set wlp2s0 up

Also just for your information if you are using Arch Linux for the first time: The Arch Wiki is extremely helpfull and almost everything is covered + troubleshoot for a lot of problems. It is the best Wiki for a Linux destribution. Worth a look! Arch Wiki

  • Thanks, I will give it a try and see what happens. Actually, I do read the wiki (probably too much) and I am often overwhelmed with possibilities. I figured I could ask someone more experienced than I before I try every option available and end up making things worse. :) – David Sep 5 '14 at 20:40
  • 1
    No luck. After this, I tried to reconnect using wifi-menu and I am getting an error "Job for netctl@wlp2s0\x2networkname.service failed. See 'systemctl status netctl......service and 'journalctl -xn' for details. Hmmm... I will look it up and see what I find. – David Sep 5 '14 at 20:52
  • I got it. I just rebooted deleted the /mnt/home directory. Then ran wifi-menu immediately and now I am getting a ping back from www.google.com. :) I guess I added too many steps and made it more complicated than it had to be. Thanks again for your help. – David Sep 5 '14 at 21:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.