0

I have been struggeling with a problem for a couple of hours. It feels like I have tried everything but nothing works. I installed linux mint 17 alongside with windows 8.1. I turned off fast boot and secure boot before doing this. I installed linux in three partitions, root , swap , home.

After installation when I restart i go directly to windows 8. So my problem here is that I want the grub menu to show.

Here is what I have tried. I go back in to linux using my USB. I run this in the terminal:

sudo add-apt-repository ppa:yannubuntu/boot-repair

sudo sh -c "sed -i 's/trusty/saucy/g' /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list"

sudo apt-get update

sudo apt-get install -y boot-repair && boot-repair

I get a message telling me "EFI is detected check options" I just ignore this and continue and the boot repair shows and I press recommended repair. It goes on and ends up with a message that boot repair completed with errors. Which is not good but then i go into windows and run this in the command prompt:

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

And this dosent help either. PLEASE help me!

  • I had the same problem when I first got my Lenovo X220. It showed an odd behavior when it comes to GRUB combined with EFI. EFI Boot files need to be in a very specific folder. You don't happen to have the same or a simliar notebook? – ap0 Sep 6 '14 at 9:42
  • Yes it is very strange! No I have a hp envy j15-160no. – George Sep 6 '14 at 12:53
0

It's possible that you are writing to the USB instead of the hard disk since the OS came from the USB. Maybe you should created the bootable CD and run that. Also, it should tell you how to fix the error.

  • I think the software looks for the hard drive and not the usb. The cd method didn't work and unfortunately the repair boot don't tell me how it fix it. It just says to copy a website and mail it to a support mail if I still have a problem. – George Sep 6 '14 at 8:32
  • At least you will get some advise from someone who knows the details about installing GRUB. – LDC3 Sep 6 '14 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.