In Firefox forward slash is mapped to quick find. Is it possible to let forward slash behave the same in Google Chrome as in Firefox? To find a link and follow it in a page in Google Chrome I now have to type:

Ctrl + F, <search query>, ESC, Enter

In Firefox this is:

/, <search query>, Enter

Not being able to use forward slash to find in page has been a real show-stopper for me as I use it all the time in Firefox to browse documentation.

  • 5
    It's obvious there are emacs saboteurs in Google's HQ ... with a plan to destroy every single key shortcut out there.
    – Rook
    Dec 9, 2009 at 11:47

8 Answers 8


Try checking out Vimium, an extension which gives you Vim keymappings. This would allow you to type a '/' and then you start typing whatever you're looking for and it dynamically jumps you to the part of the page that matches.

You may just find that the rest of the Vim keybindings are helpful too - for scrolling, navigating tabs, opening new links, etc., all without taking your hands off the keyboard - but you could simply start with the search feature and safely ignore the rest of the functionality if you're not familiar with the other bindings.


A Chromium find-as-you-type extension was recently launched that comes very near to the behavior I want.

There are several problems with the extension:

  • does not search in local pages due to restrictions on Chrome extensions (you could hack the extension to make it work though)
  • bad performance

In current versions of chrome you can do:

Ctrl + F, <search query>, Ctrl + Enter

Which is a bit more convenient compared to using ESC.


As you realized, Chrome doesn't offer a native way to modify shortcuts. As things stand, you have two options:

  1. if you are on the beta or developer channel - and are willing to install an extension - there's Shortcut manager to fulfill your remapping desires. BUT, right now, you'll have to contact the developer, since the "Find" browser action is not yet assignable;

  2. you can use a AutoHotkey script, which will map the "/" in your numeric keyboard pad to Ctrl+F, only while in Google Chrome:

    #IfWinActive, ahk_class Chrome_WindowImpl_0
    Send ^f
  • The Shortcut manager does not seem to work for Ubuntu unfortunately. Also, AutoHotkey is a Windows only solution. Thanks for a pointer in the right direction though, I'll start looking into UI automation tools for Ubuntu and see where that gets me. Dec 10, 2009 at 8:23
  • Just tried on Ubuntu, and it worked for me. You have to consider that, when you add a new shortcut, it will not work in the tabs/pages that were already open at creation time. You'll have to open a new one, and then test it. But, as I said, I don't think that "Find" is among the available browser actions (yet).
    – TataBlack
    Dec 10, 2009 at 10:00
  • Yes, I got it to work now, thanks. Still, this isn't a solution unfortunately :( Dec 11, 2009 at 21:27

I've been posting this info wherever I can find threads on FAYT:

If you want to have this feature (find as you type/FAYT) enabled in Chrome by default, go to Chromium Issue 150: Type-ahead-find and read #4 for why it's not.

Then star (vote for) the issue, tell everyone who wants FAYT enabled by default to star it, and install tokland's extension as an awesome workaround for the time being: Chrome-Type-Ahead.

Also, please join my group on LinkedIn (Chrome-Type-Ahead-Find), start a Facebook group, tweet about it, or do something to spread the word.


Update: The Chromium Find As You Type Extension comes with the '/' key search functioning out of the box. Just install the extension, and forward-slash search should start working.


For OSX users (I'm using 10.6.6)

I mapped the ⌘/ shortcut to the Chrome "Find..." command (Not as good as having a simple '/', but it will do for now...

  • Go to System Preferences
  • Choose Keyboard
  • Choose the '+' to add a shortuct
  • Choose 'Chrome' from the list of available applications
  • Type the menu title exactly as it appears on the Chrome menu... for now it's Find...
  • Type ⌘/ in the 'Keyboard Shortcut' field (for some reason you can't simply have / as the shortcut...)

Switch to Chrome and try it out


There is a problem with the AutoHotKey script that makes it unusable -- I don't think there's a way to get the desired behavior using AutoHotKey:

  1. You can't search for text containing /. This can be fixed by checking if the find textbox has focus:

     #IfWinActive, ahk_class Chrome_WindowImpl_0
       ControlGetFocus focussed, A
       if ( focussed != "ViewsTextfieldEdit1" )
        Send ^f
        Send /

    You'd have to do the same thing to allow entering / in the URL bar.

  2. You can't type / in any web page's input box displayed by Chrome! Textboxes, search boxes, drop downs, etc... I don't know a way around this. The problem is that all these form controls don't seem to be visible to AutoHotKey (try mousing over them with Window Spy and you'll notice the control under "Now Under Mouse Cursor" doesn't change).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .