0

So I have an Acer Aspire V5-131 and long story short (really, it's a long story!), I decided to do a complete wipe of the HDD (using dban). So right now the HDD is absolutely wiped, there's nothing on it. My plan was to basically then install Windows 8.1, and I created a bootable USB for it using Rufus following these instructions. Turns out, if I reboot my laptop and have that USB drive plugged in, the laptop keeps repeatedly rebooting, i.e it'll boot showing the Acer boot screen and then it'll just restart and display the boot screen again. And it does this repeatedly and never stops. Now, if I take the USB out and reboot, the problem stops.

I've been into the BIOS and have disabled secure boot, and I've changed the boot order so that USB devices have priority (I say "USB devices" since oddly enough, the boot priority order has "USB HDD", "USB CDROM", and "USB FDD") and the problem still occurs.

Interesting note though - yesterday, when my laptop was still on Ubuntu, I managed to create a bootable Windows 8 USB through the WinUSB utility but that only worked if I changed the boot mode to "Legacy BIOS". The current bootable USB I have at the moment (that I made with Rufus) won't work whether the boot mode is UEFI or Legacy BIOS.

I admit my knowledge of UEFI is severely limited but the main question is, why am I not able to install Windows when the boot order is UEFI (as I said, the laptop keeps rebooting)? Thanks very much in advance.

  • It sounds like you've set the BIOS correctly. I have a feeling your bootable USB is the problem. Either you haven't marked it as bootable or the disk contents aren't working when the device is being booted to. Can you oot the USB in another computer to verify it works? You might also want to try to burn the ISO to a DVD as a last resort. – Kinnectus Sep 7 '14 at 8:59
  • Legacy BIOS should let you boot and install. You should then be able to turn Secure Boot back on afterwards. I would use the WinUSB creator rather than, say, Rufus. – Kinnectus Sep 7 '14 at 9:01
  • Hi Chris, thanks. I just tried the bootable USB on my desktop and it works. I can't use WinUSB creator at the moment though since that's an Ubuntu app (I think so, anyway...) and my desktop is Windows 7. I can't burn anything to DVD since my laptop doesn't have a DVD drive (hence why I'm using USBs). Any ideas, still? – Chrispy Sep 7 '14 at 23:23
0

I am running Lubuntu from my USB stick on an Acer Aspire Optiplex 755. I had the same problem of not being able to boot initially until I realized you cannot have any other bootable device in the USB slots. I removed my terabyte drive from the other USB slot and voila. My Lubuntu USB stick booted up just fine after that.

If your USB keeps rebooting you haven't marked your root partition as bootable. You can mark it using gparted or you can use Boot Repair disk to repair GRUB. Just remember to choose the USB drive to write the repair to on the advanced section of Boot Repair.

Make sure your BIOS is set up to recognize USB.

I did not create a live USB I actually chose the other option during the install process and chose a 32GB USB drive and partitioned it 12GB / and 14GB /home.

When you're installing Ubuntu from a CD-ROM, slot in your flash drive and choose that as the installation target. The problem is that it will wear down your flash drive with unnecessary writes, and the solution here is to edit your /etc/fstab file so that it uses tmpfs (otherwise known as a RAM disk) for the /tmp directory. For example:

tmpfs /tmp tmpfs nosuid,nodev 0 0

If you have enough RAM you should be able to do without swap entirely, which neatly sidesteps this problem. You can also set your swap off with the swapoff command.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.