1. I'm runing an Apache server on Windows 7 using the WampServer application.
  2. I need to test some Asp.net Mvc applications so I active the IIS on windows...
  3. After that, the old Apache server that I had doesn't work any more due the IIS is using the port 80.
  4. I tried to stop the IIS, and changed the Default Site port, from 80 to 8080, and making both things the port 80 desn't get released. The default IIS site runs now on the 8080 port.
  5. Also I uninstall the IIS, and in any way the port 80 is still in use, and also I don't know what is the process that owns it...

After running: netstat -a -b -o

           Proto  Local Address          Foreign Address        State           PID
  TCP             Ltop:0                 LISTENING       4
 Can not obtain ownership information
  TCP            Ltop:0                 LISTENING       780
  TCP            Ltop:0                 LISTENING       4
 Can not obtain ownership information
  TCP            Ltop:0                 LISTENING       3112
  TCP            Ltop:0                 LISTENING       3112

I know I can to change the port that Apache use modifing the httpd.conf file, but also I have to change all the virtual hosts that I had, I would prefer not doing this.

So is there anyone knows how can I kill the process that still use the port 80???

  • 1
    Changing IIS port and restarting your server should fix it once and for all...
    – Kinnectus
    Sep 7, 2014 at 21:05
  • That works!!! Thanks, if you answer the question I will accept it! The problem was that I was not restarting the server, and when I uninstalled the IIS from the Windos features, windows keep using the port 80. Sep 7, 2014 at 21:20

2 Answers 2


Change the IIS configuration (in this case the port it is listening on) and restart the server.

Restarting the server will force all currently running services (IIS in our case) to release any configuration data. Not all services reload configuration data if you simply stop then start them.


Final solution:

  1. Change the port to the default site
  2. Restart the server

Finally this works, thanks Big Chirs!


After I think the problem was solved, it was not. So I tried to find a solution one more time, and finally I found that the Report Service of the SQL Server 2012 also open the port 80 as a windows service. I suggest to read Resolving Port 80 Conflicts, it was where I find the problem and the solution.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.