6

I have been trying to solve this problem for a long time. I have been using Chrome for more than 4 years, it is the best browser for me.

Suddenly, Chrome stopped working. I tried uninstalling it and reinstalling it more than 20 times, but it's still not working. By not working I mean I can't open pages, I can't open settings, I can't open plugin's, etc.

I have searched a lot on the Internet and I have installed many programs to remove trojans, worms, malware. But Chrome is still only working outside of sandbox.

From the Run prompt;

  • This works: chrome --no-sandbox
  • Doesn't work: chrome

My operating system is Windows 7 64-bit.

Update 1

Screenshot per user request.

chrome blank window

Update 2

When I open the Task Manager in Chrome, I see something called GigaAuthExtension. I didn't install this. Could this be the problem?

chrome task manager

Update 3

I found that I am unable to start Google Services on Windows.

Update 4

When I run chrome, I noticed this strange process: conhost.exe and the path of it starts with ??. I just see it when I run chrome the first time after restarting windows

is this a maleware?

Update 4

When I open a chrome page, I found these processes

Update 5

I found that I have a process named csrss.exe, I read that this could be either a system process or a maleware with the same system process name. I tried to right click on it and go to location, but no location open. I mean nothing opened. is that the problem?

  • Show the screenshot of the issue. For temporary solution you can use portable chrome. – crazypotato Sep 8 '14 at 13:50
  • @crazypotato I updated my question with a screenshot, the page keeps like this forever – Marco Dinatsoli Sep 8 '14 at 14:25
  • @crazypotato please if you need more information tell me – Marco Dinatsoli Sep 8 '14 at 14:26
  • What happens when you click on “Apps”? – Daniel B Sep 8 '14 at 14:26
  • @MarcoDinatsoli Have you used Chrome Sync to back up your data (extensions, saved passwords, history, bookmarks, etc.)? – Vinayak Sep 8 '14 at 14:27
2
+50

NOTE: This is not a permanent solution.

You can try installing an older version of Google Chrome and see if that works.

If this problem is introduced by a new version of Google Chrome, then it could mean there's a software conflict with something on your computer.

It might even help to read the changelogs and see what was introduced/removed/modified between the last working version of Google Chrome and the one after it. That might help pinpoint the problem.

As @harrymc suggested, you should try filing a bug report. You can do that from Chrome itself:
Chrome button → Help → Report and Issue. Or use the shortcut combination, LAlt+LShift+I

EDIT: It looks like this is a known issue. It seems very likely that the problem might be related to old software causing conflicts on your computer (as previously suggested)

You can check if a software conflict is present by visiting this page: chrome://conflicts
If you see outdated software listed there, you should update them and hopefully, that'll fix the problem.

  • many thanks for the great efforts. just one thing please, I am using now version 26, and the last version is 37, so where can I find the version 36? – Marco Dinatsoli Sep 14 '14 at 12:26
  • You can get older versions of Google Chrome here as well. – Vinayak Sep 14 '14 at 12:31
  • I just reported the bug and I mentioned to this question in the bug – Marco Dinatsoli Sep 14 '14 at 12:42
  • Nevermind. I think I found the problem. I'll edit my answer soon. – Vinayak Sep 14 '14 at 12:43
  • I already tried the conflicts page yesterday, I will try it now and update you with the list. plus I had babylon app which confluicts with chrome and I un installed it yesterday – Marco Dinatsoli Sep 14 '14 at 12:53
1

Something on your computer is conflicting with Chrome. As it also happens in Safe Mode with Network, this isn't software and has rather something to do with your hardware or display driver or Windows itself.

Try updating your display driver, preferably getting it from the manufacturer's website. If one doesn't exist, at least check if Windows Update has such a driver as an optional update. If you find such an update but it doesn't help, try toggling "Use hardware acceleration when available" in Chrome's settings to on or off, restarting Chrome each time.

It could also be a corruption in Windows, but this is not reason enough to go to the trouble of reinstalling Windows. You could check this possibility by following this article describing sfc /scannow, which scans the integrity of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible.

If everything fails, in my opinion Firefox is a very capable browser (and less buggy than Chrome).

  • I just found this chrome removal tool officially by google support.google.com/chrome/answer/… and I run it and it tells me that there is no error in my computer, I am confused about your talking about display driver, why that could be the problem:? – Marco Dinatsoli Sep 13 '14 at 22:03
  • The display driver might be involved because this is a display problem, where Chrome might be trying to use the driver cleverly to display the page faster. When you are advised to turn off hardware acceleration, the hardware in question is the video card, and the acceleration is using it in a sophisticated way. However, hardware acceleration might not be the only optimization that Chrome is attempting, unsuccessfully in your case. If you are in doubt where to find the video driver, let me know the exact make of your video card. – harrymc Sep 14 '14 at 6:18
  • I am using invedia for my display card and i updated it using windows update and the problem keeps – Marco Dinatsoli Sep 14 '14 at 11:54
  • Vinayak solved my problem :) – Marco Dinatsoli Sep 14 '14 at 12:08
  • You mean NVIDIA? Try their Automatically find drivers page (requires Java or Internet Explorer). Please note that going back to an older Chrome version is not a solution, since (1) Using an old version is a security risk, and (2) Chrome auto-updates its version so this will not hold for too long. It's possible to block the auto-update, but is really not recommended. I suggest filing a bug report with the Chrome developers and using another browser in the meantime. – harrymc Sep 14 '14 at 12:16
1

I had that problem before. I kept trying for 4 months to solve it. I thought that the problem could have happened because of a maleware, span or something.

I also thought that the graphic driver is not compatible with Chrome.

Finally The solution was to change the compatibility of Chrome to Windows Vista.

  1. Right click on chrome icon.
  2. Go to properties.
  3. Open Compatibility tab.
  4. Check the Run this program in compatibility mode for check box.
  5. Select Windows Vista.
  6. Click Apply and OK.

Hope that works for you.

  • This approach was what worked for me. On Win 10 I started to suddenly get this error. Setting compatibility to Windows 7 did the trick. – GrandmasterB Apr 17 '16 at 3:48
1

I ran into this issue, Windows 8.1 64-bit. I Had just installed "Intel Rapid Storage Technology" -- both the app and the drivers. Took me quite a bit of troubleshooting to pin it down. Ended up removing it because it was the only thing I'd changed since chrome stopped working.

Rebooted, and Tada, everything works. I should note, I could get chrome to work with "--no-sandbox" as well as running the Chrome Beta.

Hopefully this helps someone else. Uninstall Intel Rapid Storage Technology.

0

This is not the perfect solution you might be wishing for, but it may just work as a temporary fix until you can get to the bottom of this.

  1. Get Sandboxie and install it.
  2. Use Sandboxie to create a new sandbox.
  3. Run Chrome outside of its sandbox with the option --no-sandbox but inside the sandbox you created with Sandboxie.

The benefit of this is that you can continue using Chrome, while Sandboxie will provide the system protection by the means of sandboxing technology you are used to.

See this YouTube video for an overview of how Sandboxie works: http://youtu.be/iVdY2cMTjPA

  • I updated the question, could you check please? – Marco Dinatsoli Sep 11 '14 at 22:41
  • Vinayak solved my problem :) – Marco Dinatsoli Sep 14 '14 at 12:07
0

I've got exact the same problem as you Marco, it randomly appeared and I can only run Chrome(public, beta and canary) in --no-sandbox mode.

I had a conversation on Twitter with Paul Kinlan from the Google Chrome Developer Team https://twitter.com/0x1AD2/status/529563795119947776 but he couldn't help me out(yet).

Now I'm trying to run the sfc /scannow command and if that results in nothing I'll try the Software Removal Tool or Sandboxie

I tried running the scan but without results also the removal tool couldn't find anything. The only option I've left is Sandboxie.

If I come across a solution I'll update my post.

  • thanks for the asnewr, yes please if you have any update tell us, since i still have that fu..king prolbme – Marco Dinatsoli Dec 8 '14 at 18:25
  • I still have the same problems, running version 39.0.2171.71 now :\ I think it has something to do with my Windows configuration because it's working at home and there I'm running a different version. What kind of OS do you use. – 0x1ad2 Dec 9 '14 at 8:20
  • now i installed the latest version and now unfortunately, even with --no-sandbox option, Chrome is not working :( i am gonna loose my mine – Marco Dinatsoli Dec 9 '14 at 17:44
0

Check if chrome is running on compatibility mode. This happens when chrome is running with compatibility for windows xp. Try this: Right click on chrome > Properties > Compatibility. Disable compatibility mode. Relaunch chrome.

0

Here are five different solutions. I suggest trying them down in the order they are listed. I have myself encountered this problem twice both resulting from different reasons.

  1. Right click on the Chrome icon and go to Properties. Select the Compatibility tab and uncheck Run this program in compatibility mode for: option. (This may arise when Chrome updates on windows and resets to some default compatibility mode).

  2. Go to C:\Users\"Your Username"\AppData\Local\Google\Chrome\User Data\Default\Local Storage and delete all data. (You may have to unhide hidden files from folder options).

  3. Download an anti-malware software like Malwarebytes or whatever suits you and scan your system. Some malware might be causing a problem.

  4. Try un-installing and re-installing Chrome.

  5. If none of the above work, try reverting to an older version of Google Chrome, for some compatibility issues between your system and a new version of Chrome might be preventing it from functioning normally.

protected by Community Apr 3 '17 at 12:25

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.