1

I have an Acer A0756 netbook that originally came with an HDD and Windows 8. I wanted to upgrade the hard drive, so I switched the stock HDD for an SSD, on which I installed Ubuntu 12.04. However, I would still like to be able to use the Windows install as there are many engineering programs that do not play well with Linux. So, I put the stock hard drive on a SATA-to-USB dock and attempted to boot directly off the stock hard drive (now external to the netbook). Windows attempts to boot, but I consistently get an INACCESSIBLE_BOOT_DEVICE error (I believe the error code is 0xc0000001), upon which windows restarts. I tried booting in safe mode, but this failed as well, and activating debug mode did not change anything about the process. Has anyone successfully implemented something like this or does anyone have an idea what my problem could be?

4
  • The problem you describe is to be expected. Your Windows installation was configured for an AHCI controller, and you're now using USB. Running Automatic Repair might reconfigure this for you.
    – Jason
    Sep 8 '14 at 20:59
  • I can't get to Windows at all. Nothing but BSOD, so I can't run an automatic repair. It also won't let me get to a command prompt.
    – mcwayliffe
    Sep 8 '14 at 22:25
  • Open advanced startup options.
    – Jason
    Sep 8 '14 at 22:37
  • If nothing else works, you may try to boot with your Windows installation DVD to bring up the recovery menu.
    – Scott Rhee
    Sep 8 '14 at 23:12
6

I just had the same problem and found the solution in a german magazine (c’t 2013, issue 12). The article describes different three ways of installing windows to an external drive. One of the ways included cloning an existing installation to an external drive - we can skip this step.

Further on, it is necessary to edit the windows registry. Since you are running linux you can use the tool chntpw.

Mount the external windows drive and start the editor with the option -e:

$ chntpw -e /media/<username>/Windows8_OS/Windows/System32/config/SYSTEM

Fix your path accordingly.

Now we're in the chntpw command prompt. We need to edit the value BootDriverFlags in the registry to make sure windows loads the usb drivers early during boot:

First, list all keys and values in HarwareConfig. You should see a long ID of the system. Copy the identifier.

> ls HardwareConfig
[output ommited]

> ed HardwareConfig\<paste uuid>\BootDriverFlags

In my case the value was 0. The article states that it should be 0x14 which turned out good in my case.

Next, the key MountedDevices must be deleted completely. Listed in the key are usb devices that have been connected to the computer. Windows will renew the list as devices are connected.

> cd MountedDevices

Delete all known devices, because only empty keys can be deleted.

> delallv
> cd ..
> dk MountedDevices

Type q to quit the editor and save your changes. You should now be able to boot your windows installation.

3
  • 2
    Great advice, I would only add that the <paste uuid> that you want includes the curly brackets but not the greater-than and less-than symbols i.e. ed HardwareConfig\{asdfasd...ljkklj}\BootDriverFlags
    – gogoud
    Sep 9 '15 at 7:52
  • 1
    Unfortunately this great advice for Windows 8/8.1 doesn't work - in my experience - for Windows 10.
    – gogoud
    Jul 10 '16 at 5:49
  • @gogoud I was able to update to windows 10 after re-installing the drive internally, after the update I got it working externally again. See superuser.com/questions/1105414/… for details.
    – Michael
    Jul 26 '16 at 19:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.