32

I can not find a settings in TextEdit to disable line wrap. I have found only wrap to page/window.

13

This isn't possible and you can't even dig into the plist file to override this behaviour. But you can get close.

In File → Page Setup create a Custom Page size with absurdly huge margins:

enter image description here

Now select Format → Wrap to Page and TextEdit will now have horizontal scroll bars, but you'll be stuck with an annoying whitespace on the top and left side of the page.

enter image description here

  • ugh! i could have sworn there used to be a way to do this. or maybe i'm thinking of some equivalent in another OS... – Michael Dec 7 '17 at 20:33
  • looks like when you revert to the disk copy it "forgets" that you have set it up to wrap to page, so you have to do it again. not terribly helpful when an external process is frequently updating the file! – Michael Dec 7 '17 at 20:50
5

Another suggestion is to try smultron.

I don't think textedit is designed to be much more than demoware.

  • 1
    Thanks, I got another suggestion to try smultron, I have already installed it. – Željko Filipin Dec 9 '09 at 16:08
  • 1
    Feature anemic demoware; pretty useful term there. – jxramos Oct 18 '18 at 19:01
2

I know that this does not answer your question, but let me suggest you TextWrangler as a free and more featured alternative to TextEdit.

Hope it helps.

  • 2
    Thanks Pablo, I am actually looking for less features, not more. :) I will take a look at TextWrangler. – Željko Filipin Dec 9 '09 at 13:24
0

There's actually a weird bug/behavior in TextEdit on Mac which frustrates me to no end! If you zoom in or out in TextEdit, it breaks the word-wrapping feature, dead.

In other words, to get the behavior you want, simply do the following:

  1. View -> Zoom Out
  2. View -> Zoom In
  3. If not on 'Format -> Wrap to page', switch to it first*
  4. Format -> Wrap to Window *

(* This is because you have to toggle in and out of 'Wrap to Page')

Bam. No more word-wrapping.

Just tested this on both High Sierra and even Mojave. Same thing. Set that up as a macro using Automator and you can execute it from the services menu or even via a keyboard shortcut.

The down-side is there's no way to re-enable it short of selecting everything, then pasting it into a new document, or saving, then re-starting.

  • this doesn't work for me on High Sierra – Daniel V Jun 10 at 21:07
  • I just tried it and it still works as described on 10.13.6. Again, you have to use View->Zoom Out menu, not the keyboard shortcut. They have it connected differently for some reason. The former zooms the window's view area (allowing the trick) while the latter actually increases the text size. – MarqueIV Jun 11 at 14:56
  • Of course the real solution is to just switch to VS Code anyway! :) – MarqueIV Jun 11 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.