7

I have a Dell XPS 15 (L502X) that have a Core i5-2450M, 6GB RAM and a 1TB WD 5400RPM HDD. This notebook Achilles' heel is the disk. It's slow and I understand that if I do stress it to much, it lends to sloppy system performance. Multitasking is quite complicated with this disk.

The real issue, however, is that with Windows 7 and OS X Mavericks I always had consistent performance running applications in a queue. E.g. Opening an IDE and then doing anything else.

Since I upgraded to Windows 8 (and 8.1) I had issues with the disk. IO operations are much slower and the disk can easily be brought to it's knees with anything that requires much reading/writing. Even ordinary tasks as opening a web browser are clearly slower on Windows 8.1. It the disk is being stressed by any applications, the entire system will freeze with disk usage jumping to 100% (even tho reading is barely at 4MB/s).

I tried many commonly internet found solutions as installing updated Intel's AHCI drivers or disabling file indexing. I also tried multiple re installations. The situation remained the same. The system is very sloppy when it comes to disk.

One very odd issue is that Windows 7 running on a VM inside Windows 8.1 is still faster than the host system on disk issues! It reads and writes much faster and launching light programs beats the hosting system big time.

Any thoughts on that?

  • Have updated drivers? firmware? bios? – EliadTech Sep 9 '14 at 8:11
  • Yes. I have the newest drivers and bios. It's very important to notice that the system runs flawless on Windows 7 and OS X. It's just on Windows 8.1 that I have this awful disk bottleneck. – YLeven Sep 9 '14 at 12:19
  • It happened to me with an HP G62-a10 laptop and an MSI K7N2 based Desktop. Disk performance is slower after upgrading to windows 10 and 8, respectively, compared to windows 7. One possible thing is that the Storage Controller Driver on windows 10 is a Microsoft compliant one and not the vendor specific. The i/o intensive windows services (superfetch, updates, defender), just make the situation worse by increasing i/o. – basos Jul 7 '16 at 6:38
1
  1. disable windows search service (indexing)
  2. disable windows defender (realtime*)
  3. disable system protection (useless anyway, it even backups viruses lol, and many manufacturers have t heir own restore etc)
  4. disable antivirus or try another antivirus (eset is pretty good and low on resources usage)
  5. Almost like YLeven said, but set virtual memory to 512MB or 1024MB
  6. switch to a 120GB or bigger SSD, and put the 1TB HDD in a external enclosure

    • sources well my own experience with slow drives
1

Reduce the virtual disk size such as to a maximum of 512Mb.

Control Panel -> System and Security -> System -> Advance System Settings -> Performance Options -> Advanced -> Virtual Memory -> (Change...)

1

My advice is to add this DWORD (32-Bit) Value registry setting: IoPageLockLimit setting under

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management

and set it to Hex 50000. Originally I/O by default is 512 KB. There are many articles on the Internet that say that this setting is long and dead. I beg to differ. Try it and you'll notice a huge increase in response time. A hex value of 50000 should give you up to 300 MB of memory cache for I/O throughput. Experiment with higher settings if you have above 4 GB of RAM. If you want to benchmark, get a I/O monitoring utility.

  • With 8Gb RAM on a Samung Chronos 7, I will modify and report. – George Nov 3 '15 at 3:55
  • This works nicely :) – George Nov 3 '15 at 4:19
  • Arg! This technet page says the value should be in BYTES not KB technet.microsoft.com/en-us/library/cc959494.aspx. So when you set to Hex 50000, you get 327680 bytes which is less than 512 KB! (Assuming that more is better for this setting) – Jess Mar 28 '16 at 19:40
  • I tried with 500000 and there is no performance improvement. That should be about 5 MB. – Jess Mar 28 '16 at 19:54
0

have you check the health of the disk?

??

try to find out if write caching is enabled for this HD If after enabling the write caching it disables automatically, this is most likely caused by drive failure. I dont know the exact method to check it. maybe someone here could help you ^^

I know that windows 8 is putting app in ''stanby'' by writting them in ram. but if there is not enough ram, or after a while it is writing the info on the disk instead.

I dont know if this can be the issue

finally, if you dont find the source of the problem have you consider putting youre currant disk in a external drive case and putting a ssd in it??

is there anything using the disk, (check task manager)

edit::

have you check if write caching is enabled ?? I heard of some people where it was not.

Follow this procedure to disable/enable Disk Write Caching

  1. Open Computer folder
  2. right click C Drive
  3. click Properties
  4. select Hardware tab
  5. double click on the Disk Drive, or select it then click properies
  6. click on change settings
  7. go to policies tab
  8. check if enable write caching on the device is enable.

if it go back to be unchecked after you restart your computer it might mean hardware faillure.

  • Hi there! Thanks for your reply. I believe the disk is fine since if I boot Windows 7 or OS X (even inside a VM) it performs great. The situation is dire on Windows 8.1 only. Just by launching something that uses many IO operations can bring my disk access times to 2500ms+! And the odd part: Nothing is using a considerably large bandwidth on the disk when this happens. It gets to 100% while reading no more than 4MB/s. -- As for the SSD, I thought about it. But a SSD big enough to hold my multiple OS installations would be too expensive ATM. – YLeven Sep 9 '14 at 12:22
  • have you check write caching?? I add a how to in my previous post – Jeff Gravel Sep 10 '14 at 0:06
  • Yes, it's labelled as working. I'm on the verge of ditching Windows 8. It's almost ironic that I can use my disk to the full running a VM based Windows 7 installation inside Windows 8 but the host system performance is absolutely awful. – YLeven Sep 10 '14 at 13:36
0

I managed to improve the situation quite a bit. It isn't perfect yet, but the hiccups are gone and the overall performance when it comes to IO is now in line with my expectations about this system.

What I did to accomplish this was disable Windows' Superfetch and set the virtual memory manually to zero.

One should take not that disabling virtual memory isn't healthy if you're topping your RAM. As I have 6GB and usually have around 40% free on everyday usage, I found no harm in doing so.

0
  1. install hwinfo
  2. check hard drive info and find the s.m.a.r.t. section
  3. see if anything is marked as warning, etc. this will give you an idea about hard drive's health
  4. if the problems occur with different windows installations, it could be dependent on where on the disk the operating system is running from, you may see the hdd working fine when it's dealing with the part of hard drive where there are no bad sectors. so your configuration might be totally irrelevant.
  5. if your hard drive is faulty, get rid of it as soon as possible, because you can't trust a faulty hard drive and they often fail shortly after problems start to occur.

if your hard drive is healthy, update or downgrade(yes) your sata controller device driver.

also, use resource monitor to see what program is using the hard disk the most, check total reads and writes columns. you can check what program did the most disk writes and reads and post here so that we can think of other causes.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.