0

I have a memory stick which I have formatted to contain two ext2 partitions on my Ubuntu computer, one 2 GB and one 6 GB. I would like to use them on my Windows 7 computer now.

I am aware of Ext2Fsd and I have downloaded it, but I can only see one partition in Explorer. (The first, 2 GB one.)

I also have read this question about multiple partitions on memory sticks in Windows XP. In Windows XP memory sticks can only have one partition, but I am not sure if that has changed in Vista or 7. Also, I am sure I have sometime used a memory stick on the same computer that had two partitions (a big one named PUBLIC and a small one named SECURE, if that makes any difference).

I could try use the method suggested on the page to flip the removable bit, but I'm not very excited about the risk to lose my data.

Is there a way around this, or do I just have to keep using my Ubuntu computer?

UPDATE. I checked the Ext2 Manager, and here's a screenshot.

Screenshot

I believe the partition in question is the one on DISK 1 that is identified as FAT32X. (I'm quite sure it is ext2, though.) I tried opening its properties.

Screenshot

I then clicked Mount Points. Nothing was on the list, so I clicked Add.

Screenshot

I first tried with the default option (in the picture). Clicking OK didn't add anything to the list, so I tried with the first option (via DefineDosDevice). This added H: to the list, so I clicked Done. Now H: is not being added to the Mount Points textbox (still looks like screenshot 2).

Clicking Exit now put H: next to the drive in the list, but it's still not working.

Screenshot

  • 1
    Why not copy the files off of the memory stick, format it with NTFS, copy the files back on? Ubuntu supports reading/writing to a NTFS partition. – Adam Sep 9 '14 at 15:27
  • The smaller partition is bootable, and I'm not sure all BIOSes work with NTFS. – PurkkaKoodari Sep 9 '14 at 17:16
  • Just noticed this question is still open. Did you get it working? – fixer1234 Nov 12 '14 at 9:27
  • @fixer1234 Seems like I kinda forgot about this. Updating question. – PurkkaKoodari Nov 12 '14 at 9:41
  • @fixer1234 Okay, added a lot of pictures. – PurkkaKoodari Nov 12 '14 at 9:49
0

Open the manager view by double-clicking Ext2Fsd in the start menu. See if you can see the second partition there. If so, highlight it and choose one of the mounting options.

| improve this answer | |
  • All right, I'll try when I get on my computer. – PurkkaKoodari Sep 10 '14 at 5:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.