1

Is there way to boot Linux from external USB SSD drive, attached to Windows 7 machine?(without altering or modification the Windows Boot Configuration Data(BCD)) The same way as boot with bootable Linux Live CD, by selecting USB boot device in the Boot Device Menu (F12) before windows startup. I installed Linux on USB external SSD drive, but it not booting when I select "Removable Devices" in Windows boot menu before windows start up. Didn't find what can be the problem. Possibly Windows have poor support for booting from USB devices.

1

What you describe should work. If you go to the boot device menu and the external drive is displayed as an option, you should be able to boot from it if that drive is bootable. It sounds like the problem is with the configuration of external drive. One thing to check: plug the external drive directly into a USB port on the computer itself, not a USB hub.

Another thing to check: try using the external drive to boot another computer just as a test. I've run into situations where I installed Linux on an external SSD using an old XP-age computer and the drive would boot on that computer but not another computer with more current hardware. I reinstalled Linux on the external drive using the newer computer and it then worked on all machines.

| improve this answer | |
  • Edit: I used wrong item in boot menu. When I set boot order to "USB storage", it show black screen with message "GRUB Loading. Welcome to GRUB!" and a blinking cursor. Can't wait forever to verify if it hung or stalled. – triwo Sep 9 '14 at 22:08
  • Booting should start within a few seconds of seeing the GRUB message. I would just try reinstalling it. – fixer1234 Sep 9 '14 at 23:35
  • Linux installation process asked me to install the boot loader to Master boot record at "/dev/sda"(my internal hard drive), and to get sort of dual-boot system, but I specified to install bootloader to "/dev/sdb" (SSD drive), because I don't want modification of Windows Boot Configuration Data (BCD) on an internal hard drive, where is installed Windows OS. – triwo Sep 10 '14 at 10:29
  • For what you want to do, /dev/sdb would be the right location and it sounds like grub is working. When you installed Linux on the external drive, did you format it as a bootable drive (you designate the partition as a boot partition, which provides a MBR)? – fixer1234 Sep 10 '14 at 15:04
  • I have a separate /boot partition (ext4) and specified bootable flag: on. – triwo Sep 10 '14 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.