22

I've tried all the solutions available on different forums. This is the configuration of my system:

  • Pentium Dual Core T230 (1.73 + 1.73), 2gb RAM
  • Oracle VM VirtualBox ver. 4.3.14 r95030

This is the configuration of my guest:

  • Windows 7 with 1gb of RAM assigned to it and 20gb of hdd

The task manager of my host shows 100% CPU activity even when the guest is idle.

I've also made a DOS machine which is suggested to do nothing and that reduces the CPU activity to about 56% but not as same as it should be when my host and guests are idle.

Another solution available to me was to set the affinity of VirtualBox to a single processor but I'm not able to do that, it denied the access. I'm logged in as administrator and have also checked "Show processes from all users".

migrated from serverfault.com Sep 9 '14 at 18:35

This question came from our site for system and network administrators.

  • are the guest additions installed on the VM? Are there any background processes that might be running that can cause issues? I have seen screen savers bring VM and their hosts to a halt. – Keltari Sep 9 '14 at 19:40
5

Your processor does not offer hardware-assisted virtualization so VirtualBox is using software-based techniques, which will use more CPU time and make everything slow.

Read more about it here.

  • 4
    even without virtualization support, it should not be using 100% of the processor – Keltari Sep 9 '14 at 19:39
  • I presume the OP meant a T2300, which does actually have VT-x. It's not a great chip, tho, otherwise. ark.intel.com/products/27233/… – tudor Oct 31 '16 at 4:00
  • This answer isn't so useful… It highlights a limitation, but does not offer a solution to this problem, even though solutions seem to exist. – Clément Jan 22 '18 at 20:53
5

I had this issue with 2D Video Acceleration enabled. Once I disabled it in the Virtualbox machine settings, the host high CPU usage was gone.

5

also try this alternative where the guy disables "Nested Paging". It worked for me reducing 16% of cpu usage.

If you’re not familiar with this setting. Shut down your virtual machine so that you can edit the settings. Then go to the system tab, click on Acceleration and then uncheck the Enable Nested Paging checkbox. Click OK and start the virtual machine up and you should quickly notice some performance improvements.

  • 1
    That worked perfectly on my set-up. I wish your answer was more detailed, but I admit this is the working solution (on my set-up, at least). – Clément Jan 22 '18 at 20:51
  • I've added a more detailed explanation from the source link – Facundo Colombier Jan 23 '18 at 21:44
  • 2
    Perfect, thanks! I went to occasional 100% CPU load while idle to no more than ~20%! – Clément Jan 24 '18 at 15:31
  • 2
    Just a warning, this is hardware dependent. On my host, disabling nested paging made the guest totally unusable. Both assigned CPU cores were pinned to 100% just trying to render the login screen and it sat like that for 5min until I shut it down and re-enabled this setting. – theferrit32 Apr 22 at 19:27
1

There seem to be many different causes for high CPU use on the host.

In my case, with a Win7 guest, the solution was to disable the "VirtualBox Remote Desktop Extension".

Either in Settings -> Display -> Remote Display: unselect "Enable Server".

Or by starting the machine with the -vrde off option.

0

If you've just set up the machine it's probably windows update. It can't be seen in the process list and is extremely CPU hungry. Had this problem multiple times.

Go to services, find windows update, stop it, see if it drops the CPU usage. If it does consider disabling it completely.

  • Agreed that windows update could be the culprit on a new machine but let it finish, don't disable updates. That is a terrible idea if you plan the VM to persist more than a few days. – cornasdf Jan 31 '18 at 23:36
0

None of the above worked for me with an old Acer laptop, 2 x86 CPU cores; 3 gigs of RAM, running Win XP SP3 Host, and Win 7 guest (on VirtualBox 5.0.24). My "Acceleration" tab is disabled, so "Nested Paging" is not enabled. Also "Remote Display" was by default disabled. The VirtualBox panel had automatically disabled selection of any number of CPU cores, and was stuck on 1 CPU (although my Host system tray clearly shows the involvement of both CPU cores). Also the Windows Update of the guest machine was already disabled.

However, my guest machine took up at least 50% of CPU even when idle.

My solution? The problem solved only when I enabled both the 2D and 3D accelerations in "Settings -> Display -> Screen" and then increased the "Video Memory" in the same tab ("Settings -> Display -> Screen") to the maximum 256 meg allowed.

Once the guest machine received a good deal of video memory from the RAM, the CPU usage dropped to a nice 10% to 20%.

  • This worked for me. Why was it downvoted? – daniel sp Mar 20 at 8:23
  • I don't know why it was downvoted, but I got disappointed by the anonymous idiot who did that. I am glad it was of help. :) – Vic Mar 20 at 10:39