0

To paraphrase the old joke, I think I have right field so screwed up no one can play it anymore.

I installed WordPress on our intranet dev server (IIS 7, Win 2008 R2) using the web platform installer. I set it up as a separate website on port 8080 because I thought that installing it at the root would overwrite all our web apps. I was able to get to the WP content and wp-admin main pages while remote desktopped into the server, but could not connect to anything from elsewhere on our intranet. I tried http://devserveruri/wordpress, where devserveruri is the uri of our dev server. I tried http://dev.decisionsupport/wordpress, where dev.decisionsupport is our local DNS entry for our dev server. I googled around and didn't find this exact situation. I brought in our alpha programmer, and he suggested I reinstall into an app directory under the default web site. So I did and now if I try to connect to http://devserveruri/wordpress/ the page returned shows devserveruri:8080/wordpress/ in the address bar and Chrome shows "The web page is not available." I did not install this second time to use port 8080. http://dev.decisionsupport/wordpress/ returns the WordPress landing page, but it is devoid of formatting or styles, and every link on that page is a variation on localhost/wordpress.

I am at a loss as to how to troubleshoot this. I don't see anywhere in IIS where port 8080 is even mentioned. The bindings for the default web site only refer to port 80. Any ideas as to what I should do next?

EDIT: My goal is to use WordPress as a landing page for our intranet, with links to our homegrown ASP.NET applications. Is there a better way to install WP instead of how I did it? (Not trying to create any abominations here).

EDIT: Thanks @gronostaj, that was the answer. Replaced the WordPress Address (URL) on the Settings page with http://dev.decisionsupport/wordpress and it worked.

  • Your config must be OK because you get the WP landing page?! Have you gone into the WP admin interface and made sure the site address matches where your site is? As your setup isn't who's standard you may have some additional settings to contend with. Also what does your app config for IIS have (WP usually works with htaccess)? There are sample config files for IIS. – Kinnectus Sep 9 '14 at 21:25
  • Wordpress asks for its base URI during initial setup and uses it later. You have probably entered localhost there instead of dev.decisionsupport/wordpress. – gronostaj Sep 10 '14 at 16:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.