1

I am using plugin DSpellCheck in Notepad++

When editing an XML file I noticed that the spell checker does not check inside the "CDATA", like this:

<![CDATA[My testt]]>

What causes this is the exclamation mark (!)

Other example not work:

<!

testt

>
testt

The spell checker does not work inside "comment tag", but this work fine:

<!--

testt

>
testt

These are the delimiters in configs:

,.!?":;{}()[]\/=+-^$*<>|#$@%&~…№—«»–•©›“”· `→×

How to configure DSpellCheck/Hunspell to work?

  • 1
    It's possible this is intentional. CDATA is meant to be "This is seriously explicitly what I want to send, no matter what single quotes, double quotes, null characters or other chaff are present in here it REALLY SERIOUSLY is what I want to send". Otherwise it's an issue with the RegEx used to locate things to spellcheck. – MrDoom Sep 21 '14 at 4:21
  • 1
    @MrDoom No matter what it is. It is a text and a text should be spellchecked specially Comments, when others wanna read it ... – UltraDEVV Sep 23 '14 at 12:59
2
+50

First: You forget to add -- at the end of > . LIKE THIS <!-- dfsdf -->.
Also it works on my computer with no problem. What Ive found is that:

  • You maybe have some problem in "Filetypes" of DSpellCheck settings, check it. It should be *.*
  • Also when I unchecked the Check only Comments and Strings If Possible text inside CDATA went into what you want.

I post some pics:

When it was checked:

Checkhed

When I unckecked it:

UnCkecked

  • 1
    Disable Check only Comments and Strings work fine! – Guilherme Nascimento Sep 23 '14 at 13:01
  • Im Glad ! ;) :D – UltraDEVV Sep 23 '14 at 13:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.