0

I installed FTP Server Services on my IIS 8.5/Windows 7 workstation, and tried to FTP using FileZilla from my laptop (client - Windows 8). I tried to configure the Network Settings using Network Wizard on FileZilla, and here is the output. [I have masked the IP with 'x' on the output for privacy]

Connecting to probe.filezilla-project.org
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.9.0.5
Response: 230 logged on.
Checking for correct external IP address
IP xxx.xxx.xxx.xxx bdj-bac-bgd-ic
Response: 200 OK
PREP 50307
Response: 200 Using port 50307, data token 860523756
PORT 139,102,163,82,196,131
Response: 200 PORT command successful
LIST
Response: 150 opening data connection
Response: 503 Failure of data connection.
Server sent unexpected reply.
Connection closed

I also tried to FTP from the laptop using Windows PowerShell, I was able to connect but when I try to get file, I get the following error.

ftp> get file.jpg
200 PORT command successful.
125 Data connection already open; Transfer starting.
> .:No CSI structure available
550 Access is denied.
ftp: 131072 bytes received in 0.15Seconds 891.65Kbytes/sec.

Then I started an SSH session using PuTTY, and tried FTP to the same server & everything worked fine.

I want FTP to work from FileZilla on my laptop. What configuration setting may be missing?

2

it looks like you are using FTP active mode, which requires an additional port on client for data transfer. https://wiki.filezilla-project.org/Network_Configuration#Active_mode

you may try using passive mode instead or configure firewall on your client/network

  • Not trying "Active" mode. – Kunal B. Sep 10 '14 at 15:45
1

Regardless of whether you want to use active or passive FTP you're going to have to forward some ports. The difference is only in which ports and on which side of the connection.

Active will require forwarding ports on the client so the server can connect to it for the data connection when the client issues the PORT command.

Passive will require forwarding ports on the server so the client can connect to the port the server repsonded to the PASV command with.

You can read Basics of FTP to get an overview of both methods and general port ranges.

According to configuring ftp firewall settings in IIS in order to setup a passive port range you should select FTP Firewall Support within the server node and configure the Data Channel Port Range option. Although the guide is for IIS 7.5, the same options exist in IIS 8.5

1

As others mentioned, you ARE using an active mode in the wizard. See the PORT command in the log, that's what is used for the active mode. For a passive mode, PASV would be used. In most cases using the active mode won't work, because it requires you to have a port range opened in your Windows firewall for incoming data connections. See my article on Network configuration for active and passive FTP modes for details.

The Allow fallback to other transfer mode on failure option in the wizard apparently only sets respective preference option in FileZilla (Connection > FTP > Transfer Mode). It affects normal connections later, but obviously has no effect on the wizard itself (I've got the same results on my machine).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.