0

I recently bought a 750GB WD disk for a netbook and formatted it while connected via a USB adapter. Because the adapter would disconnect when it was trying to access the ext4 journal, I connected it to another, which proved to work fine while I was copying hundreds of GBs of data from the old disk. Now that I tried to connect it to the netbook, the partition table was found corrupted by fdisk and parted. In particular, I am only able to see the primary partitions, none of the extended ones. I recall that when connected to the USB adapters both logical and physical sector sizes were 4kB, while in the laptop they are 512B/4kB, which may explain the problems encountered.

While trying parted in the netbook, it could rescue only the first partition, starting from sector 2048 and ending at 146430, which means that its size is ~75MB, which is about 8 times smaller than the size formatted while connected on the USB adapter. Also, attempts to mount it fail with

Failed to read last sector (144383): Invalid argument

Considering that I have no easy way to copy again the files from the failing disk, is there a way to make the data on the disk accessible while inside the netbook?

EDIT

Because the old disk was 512B/512B, I was able to connect it to the USB adapter and transfer the files to the new disk inside the netbook successfully.

  • Have you ran the command to the MBR? The sector size is declared by the HDD not the computer itself by the way. So your theory is extremely flawed. – Ramhound Sep 10 '14 at 18:31
  • What command do you mean? I know that about the sector size, the problem is that different controllers report different values to the OS. – auxsvr Sep 10 '14 at 18:40
  • The controller is going to communicate with the HDD's firmware and ask what the sector size is. how to fix mbr – Ramhound Sep 10 '14 at 18:46
  • "its size is ~75MB, which is about 8 times smaller". Sounds like exactly 8 times smaller, because 512bytes x4 = 4096bytes (aka 4K). – Robin Hood Sep 10 '14 at 23:48
0

An alternative solution would be to use TestDisk to do a deeper scan and then press P to get access to the files list inside your disc, which also allows to recursively copy all the files. This is what I did in a similar case as yours, and it worked greatly (because I had not access to a 512B USB adapter...).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.