1

I want to access my home machine from internet. Since I don't have a static IP I am trying to use DDNS. For that, I've registered a free domain(alihammad.ddns.net) with Noip.com, it binds my external IP (101.50.xx.x) with the domain name. I've also configured my router DDNS settings

Router: TP-Link TL-WR740N Routeer Firmware: DD-WRT v24-sp2 (11/21/10) std

enter image description here

I am also forwarding two ports, 80 for web and 22 for ssh. enter image description here

Now if I ping my domain (alihammad.ddns.net) from LAN, it works. But, if I ping the same domain from another network, it doesn't work.

Please guide?

  • 2
    You can't ping because you only forwarded 80 and 22. The ping stops at the router, as it should. – Tyson Sep 11 '14 at 1:58
3

The reason you're seeing failed pings is that DD-WRT blocks anonymous ping requests by default (any competent router should do this as well). It helps to prevent people from "seeing" you on the internet, therefore improving your security a little bit.

You'll likely need to open and forward ports, depending on what you're planning on doing.

  • Any way to unblock it? – Ali Sep 11 '14 at 6:25
  • 1
    @Ali Sure, but I'd highly go against this. It's in the Security page. Untick Block Anonymous WAN Requests (ping). – happy_soil Sep 11 '14 at 6:46
0

I would say it's because your System Firewall or any Antivirus automatically blocked your port to access to server from external connections, but you can still connect with LAN. Make sure you set the rules for Firewall, bind the port you needed in your Antivirus. Then go to this site: http://www.canyouseeme.org to check the port connection.

  • I've checked so many ports and seems like none is open. Disabled the firewall and still no progress – Ali Sep 10 '14 at 23:26
  • Well then maybe you will need a DUC (Dynamic Update Client) from No-IP if you are using a dynamic IP. Alternatively you can switch to a Static IP. – samillwong Sep 11 '14 at 1:12
0

I hope you found your solution, but for people looking for an answer:

When you forward a port on your router, you need to specify the IP of the device which host the service. In your forwarding table you use 192.168.53.1 which is the router IP.

So if your Web server is on 192.168.53.10, you should use this address. Also to be sure that the device keeps the same IP address, you should use the MAC/IP binding.

In order to know your IP address/ MAC address: Windows: Win + R, execute "cmd" (or "cmd.exe"), and type "ipconfig" press enter. Mac/Linux: launch a terminal, and type "ifconfig" press enter.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.