6

The mouse pointer in my Ubuntu 8.04.3 LTS VM (running in VMware Fusion) has changed into a little hand holding a document. It doesn't show up in screen-shots.

All mouse clicks (left or right) are ignored. But I can still type in the one Terminal window I have open. (And commands work fine.)

I wonder if I'm in some kind of drag-and-drop mode.

How do I get out of this?

Update: Rebooting (from the command-line) worked. Ubuntu came up with the regular mouse-pointer.

| |
  • Hey Daryl. If that command-line reboot has fixed the problem, you may want to add your fix as an answer to your own question, then accept it. – RJFalconer Jan 9 '10 at 2:01
2

The only solution I've found is to reboot.

| |
2

I solved it (without having to reboot) by performing these steps. Which was basically dragging some text from the host to the guest machine.

I think I had the same problem as what you have - can't be sure though. Try it anyway.

| |
  • Clicking on the URL gives: Error. Page cannot be displayed. Please contact your service provider for more details. (26) – boardrider Aug 23 '19 at 18:20
1

Switching to a VT via CtrlAltF2 or the like, logging in, and then killing the app via kill will release the lock on the pointer.

| |
  • After doing this, you can use Ctrl+Alt+F7 to get back to the GUI – Jake Toronto Jul 31 '15 at 17:14
1

If you do Ctrl + Alt + F1 followed by Ctrl + Alt + F7, this may fix the problem.

| |
  • 3
    Why? Can you elaborate on what this does? (it should switch to a tty and back to X, but why does that help?) – bertieb Aug 26 '15 at 22:43
  • I think it's because it stops drawing the pointer, and when you return to GUI, it must redraw it – Caleb Eby Oct 16 '15 at 15:15
0

Just logging out (Ctrl+Alt+Del) solved the issue for me

| |

Not the answer you're looking for? Browse other questions tagged or ask your own question.