17

Basic background tech info:

  1. Host: Windows 8.1
  2. Guest: Linux Mint 17
  3. VMWare Player version: 6.0.3 build-1895310
  4. Host hardware: ASUS Laptop with broadcomm wifi chipset

In the past (earlier versions of Linux Mint, and earlier versions of VMWare Player), I could switch networking between NAT and Bridged, and both would work as expected. I settled on NAT. Recently, I had need to switch to Bridged, and the guest Linux OS failed to connect. Switch back to NAT, and everything reconnects and works fine.

I've updated VMWare Tools in the guest OS, with no effect. Alas, I don't know which Mint upgrade, or VMWare Player upgrade broke the functionality, or when.

Variations of this question seem to crop up frequently, but none of the questions I've read here on Superuser seem to directly address, or offer a fix for, this problem.

Happy to provide logfiles or other info to help debug the issue. Just let me know what you need. Since I can use NAT as a work-around, this isn't urgent. However, I'd like to understand what's wrong and fix it.

Thanks.

14 Answers 14

23

There is another, not so 'brutal' approach to fixing this. This has bit me more than once. Go to the VMWare Virtual Network Editor, and in the VMNet Information section for "Bridged", pull the drop down "Bridged to:" and change from Automatic to your physical adapter name. This allows both VMWare and VirtualBox to play together on the same host. (I'm surprised that VMWare does not detect this where the host has more than 1 VM application installed)

| improve this answer | |
  • 1
    a simple solution that worked for me as well – iBabur Mar 30 '15 at 11:04
  • I am so glad that i found this answer! I completely forgot that i have installed virtualBox and i noticed that after a few restarts I could use my bridged network. Thanks! – Slava Babin Jul 11 '17 at 18:02
14

Found a solution for my version of the problem. Hope it helps someone else.

Previously, I had been using VirtualBox. Switching over to VMWare (using NAT) worked just fine, but VirtualBox had left a host-only adapter in Windows Networking, which was (silently) making "bridged" mode in VMWare not work.

I hit a similar issue installing "boot2docker" (which uses VirtualBox) on an other machine which had VMWare working, which then stopped after installing "boot2docker". Diagnosis of that led me to VirtualBox being the culprit.

SOLUTON:

On the windows host, go to Networking Connections, and "disable" any VirtualBox network entries there. Your "Bridged" VMWare connections will start working again.

| improve this answer | |
7

You don't have to disable the VirtualBox adapters in Windows. You can fix this within VMWare Player directly. Go into your VM Network settings, select Bridged, and then click the Configure Adapters button. Uncheck "VirtualBox Host-Only Ethernet Adapter".

This will fix your problem and leave the VirtualBox adapters functional in Windows so that you can use both VB and VMWare on the same system without having to constantly switch settings.

| improve this answer | |
3

The only thing that fixed my connection was to add another network adapter (NAT) on top of the existing one.

Manage -> Virtual Machine Settings -> Add -> Network Adapter -> Finish.

| improve this answer | |
  • I can confirm that I've had to do this exact thing a few times - it's almost like VMWare loses the connection to the virtual NIC on the host, and creating a new NIC on the guest reestablishes it. – Mikey T.K. Feb 15 '19 at 16:44
  • This actually worked – smac89 Feb 24 '19 at 22:14
2

I found that in VMware Player, there is no network editor. However, you can specify which adapter to bridge to, and that resolved the problem for me. In the screen below, both adapters were selected. De-select the Hyper-V, leaving only the physical adapter.

enter image description here

| improve this answer | |
0

I would also like to mention in addition to these answers that host Firewall Particularly Firewall Clients/Software (in my case AVG Firewall) may interfere with the Bridge adapter for Vmware, try disabling the firewall software

| improve this answer | |
0

I have a similiar problem, and it was caused by that I have 2 network card(eth/wifi) on my host and both connected to internet. When I disabled one, the problem was gone.

| improve this answer | |
0

On my installation it was an installation of npcap (with wireshark) on the host that broke the virtual connections. Going into vmware network config and disabling the npcap adapter for the vm restored the connection

| improve this answer | |
0

In VMWare Workstation Player, I had to do two things:

1) In my Windows network adapter options, under Properties for the adapter I use to connect to the LAN, I had to make sure the VMWare Bridge Protocol box was checked.

2) In the VMWare Network Adapter settings, as others have mentioned, make sure the only adapter checked in Configure Adapters is the adapter you are using to connect to the LAN.

After doing those two things, I restarted my computer and then my VM and the network connected successfully. Hope this helps!

| improve this answer | |
0

In my case it turned out to be a confused router, just needed to unplug/replug power. This after trying all of the above heh. I noticed going to the routers admin page wasn't working that's when I unplugged it and reboot, then bridged networking came back to life! so check that too...

| improve this answer | |
0

i was facing the same issue, almost done the VMware repair, re-installation. and also restored the setting to default in virtual network editor, but same issue.

lastly i tried that, uninstalled the Bridged adaptor from Virtual network editor and reinstalled the same. and it started working,

Just make sure vm is not on while your making changes in virtual network editor.

i hope this works for you..

| improve this answer | |
  • Are you certain this is not a duplicate answer? Others mention the bridge mode on the adapter too so just curious if the end result of uninstall and reinstalling has the same outcome as messing with the bridge mode as other answers indicate. Even if uninstall and reinstall it is not mentioned, I just wonder if it's still basically just enabling or disabling or changing the mode, etc. to make it work which is essentially just a different way making that happen. Think about it and tag me back with your thought or edit accordingly if needed. I'm not sure, just mentioning the thought. – Pimp Juice IT May 30 at 16:52
0

I had this issue too I tried everything related to disabling adapters, messing around with Virtual Network Editor, etc. But non worked. My setup:

  • VMWare Workstation 15 Pro
  • Host: Windows 10 Enterprise, version 1909
  • Guest: Windows 2012 R2 Datacenter

SOLUTION:

I noticed that the result of ipconfig command on guest shows weird IP and netmask. So I tried to manually set the IPv4 options for the bridge adapter(Ethernet0) in control panel of the guest. Setting the right subnetmask, gateway and IP made it work.

| improve this answer | |
0

Thanks to JesseM reply, i went to check the adapters but the virtual box was already deactivated. the WSL was the culprit. For Anyone on newer windows 10 with WSL activated, the bridged network started to work fine as soon as i disabled the WSL Adapter in Networking Connections"

| improve this answer | |
-1

I was using a bridged connection for a Kubuntu VM. It suddenly stopped working, no idea why. I fixed it by entering the console command "nmcli networking on".

I have absolutely no idea why this worked.

| improve this answer | |
  • 1
    You make it sound like you pressed random keys and they happened to spell "nmcli networking on", and magically, it worked. Surely, you had some reason to try that command. – fixer1234 Jan 27 '19 at 23:33
  • 2
    I was in a 6 hour daze trying to fix this by typing in random c**p from stackexchange, sweating with desperation. I entered a fugue state and woke naked in a field with my laptop's VM connection fixed and the command "nmcli networking on" written in twigs next to me. – Josh Porter Mar 10 '19 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.