Windows 8.1 suddenly reported from the notification area that it hasn't been able to run updates for over a while now. The metro-style update app doesn't tell me much about why the updates are failing, but the desktop-app does have a message (some emphasis mine):

Windows could not search for new updates

There was a problem checking for updates.

Error(s) found: Code 80244007

It looks like this:

control panel

The weird thing is, if I check the update history, I do actually see more recent updates:

recent update history

I've tried a few things to get this resolved.

First I've tried various ways of shutting down- and restarting my PC, hoping it would miraculously start finishing the updates. This did not work.

Second, I've gone through MS Knowledgebase 2883975 that describes my problem...
...which told me to go to MS Knowledgebase 2883201
...which told me to either run Windows udpate :P
...or to go to the MS Download Center
...where I should search for "KB2883201"
...where I chose the Windows 8 x-64 download
...which gave me:

This update is not applicable to this comptuer

I thought that it made some sense, because the filename has "RT" in it. So I also tried the plain Windows 8 download, but it presents me the same error message.

Third, I did some more searching also got me to a page that promises this error will be solved by running some "Windows Repair Tool" executable, but the page is very vague and generic so I've held back trying it.

Finally, a related post on answers.microsoft.com suggested running sfc /scannow, which I tried but came back with no problems after 100% verification.

As a (probably important) footnote, I think I'm probably debet to this problem. When setting up my PC I mistakenly chose "Windows 8 Enterprise" from my MSDN subscription, even though I'm not in an enterprise situation (I should've picked any kind of "Pro" version I guess). We have no server distributing updates for our domain, or anything like that.

I need my Windows 8 installation to get updates on its own. This has worked just fine in the past, only recently has it started getting problems.

Anyways: what can I do to get Windows to start updating again?

Here's any additional pieces of info that may (or may not) be important:

  • My PC is part of a small domain. We have no centralized updates-distributing server (like I mentioned, I installed the Enterprise addition by mistake).
  • the code means this: WU_E_PT_SOAPCLIENT_SOAPFAULT: Same as SOAPCLIENT_SOAPFAULT - SOAP client failed because there was a SOAP fault for reasons of WU_E_PT_SOAP_* error codes. But I have no idea how to fix this. – magicandre1981 Sep 11 '14 at 19:29
  • @harrymc :-) the bounty was super effective: very shortly after posting the bounty someone answered it! Being a good SO citizen I immediately tested the offered solution, and it solved my problem it seems so I accepted the answer. Like I wrote in my comment to the answer, if the solution holds up I'll also award the bounty. I'm just waiting a little bit, since undoing an awarded bounty isn't possible (whereas undoing an "accept" is). – Jeroen Oct 13 '14 at 13:52
  • The case of the too-fast answer. – harrymc Oct 13 '14 at 14:23

Since you're connected to a domain, I assume it's an invalid Target Group name. So what you have to do is to open the registry, and then go to : HKLM\Software\Policies\Microsoft\Windows\WindowsUpdate

And then look for Target Group key, export it first (just a backup) then delete it.

Now, restart your computer and check Windows Updates.

  • 4
    Awesome, your answer led to my solution! The Target Group key was set to my domain name. Removing it wasn't enough, but after I also removed (in some order, not sure which fixed it) the TargetGroupEnabled, WUServer, and WUStatusServer keys, updates were working again. – Jeroen Oct 13 '14 at 9:47
  • Let me double check that everything's working fine for next two days, if so I'll happily award you the bounty! – Jeroen Oct 13 '14 at 9:49
  • I'm happy that leaded to a solution, your problem isn't just deleting the Target Group, an invalid Target Group means invalid group membership name, which is one of the core requirement to evaluate update approvals from the WSUS server. So, if is it somehow corrupted or invalid, the WSUS will deny the connection. – iSR5 Oct 13 '14 at 12:19

I got the same error on a Windows 10 (1511) computer. In my case, deleting C:\Windows\SoftwareDistribution\DataStore\DataStore.edb worked:

net stop wuauserv
del C:\Windows\SoftwareDistribution\DataStore\Datastore.edb
net start wuauserv
wuauclt /detectnow

This solution was not my idea, but was suggested by Frank Maxwitat here.

The problem appeared after running the Server Cleanup Wizard on the WSUS server used by this computer. However, there was a different problem before running the cleanup, so it might be that this problem simply got hidden by the other problem before the cleanup.


I have seen such errors when trying to install updates on a Windows 8 pc, when the time was not correctly synchronized with the time server. That would also clarrify why you see more recent updates in the update history.

Can u check your clock to be correctly synchronized? If you click on the clock in the taskbar, you can chose for 'Change time and date settings...", then go to the 'Internet Time' tab. When did your pc synchronized the time? Maybe try to click 'Change settings...', make sure the serveradres is 'time.windows.com' and then press 'Update now'.

  • Thanks for your answer. The date and time settings has no "Internet Time" tab though, perhaps because my PC is part of a domain? Either way, checking the registry it does look like time.windows.com is my time provider. In any case, my PC time seems to be correct. – Jeroen Sep 11 '14 at 8:17
  • Then something else will cause the problem, if I know anything I will let u know. – Kevin Sep 11 '14 at 8:30
  • You tell us if it's part of a domain... – Ramhound Sep 12 '14 at 2:31
  • @Ramhound Yes. I've added it as additional details to my question. – Jeroen Oct 13 '14 at 8:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.