1

I have to go to Korean websites a good amount; however, there are some times when Korean is not being displayed well at all. It took me a while to figure out why certain Korean test was displayed well, but others were not.

I have finally found the culprit, and it is that I don't have Korean support in Adobe Flash Player. I tried researching how to enable Korean support, and how to download a package to add Korean support; however, I have not been able to do that.

How can I add Korean support to Adobe Flash Player?

In the image below, if you right-click on the element above the green line, you will get the following context menu. From the menu a person can conclude that is a flash element, and thus Adobe Flash Player does not have Korean support.

enter image description here

UPDATE

While looking for more information on this, I found some other people have had this issue too, but no solutions have been posted. I just wanted to point out one thing here. Korean websites tend to use Flash for menus, but some Korean text in the menus are showing up. Take the example for the picture below! That whole menu is a Flash Player object; however, but some Korean is displayed.

enter image description here

2

I don't believe that you need Korean support or something for Adobe Flash.

Please check these things:

  • Are those strings written in Unicode?
  • Does the system have Korean fonts? e.g. Gullim.

On the 2nd screenshot, it's pretty obvious for me that the "well-displayed" texts are not texts, but captured images processed by PhotoShop or something so that they aren't affected by any encoding/font issues at all. On your screenshots, I don't see any "real" texts (say, not image-texts) displayed correctly. Probably the flash programmer did not set UTF-8 encoding on their resource xml files, which is a very common problem in South Korea. They just don't care because most of developers and users use Korean Windows.

Hence, you can take the same approach - change system default locale to Korean. If set, all "non-Unicode" applications will work as if they run on Korean Windows. So if you don't like this side-effect, don't try this. This is not the best solution, but at least the flash will display Korean texts correctly.

  • Control panel -> Region and Language -> Administrative -> Change system locale -> Select "Korean". You may need to install East-Asian language pack to do this.

The best way is, I believe, contact the flash developer who designed that web site and ask to update their flash controls to use UTF-8 encoding there.

Are those pages available on Internet to share the links? If so, I can give them a try and investigate little bit further.

[UPDATE]

I visited the page that Christopher linked. For me, it's obvious that the Flash control was not made correctly. If you see some Korean characters on the page (not on the SWF control) which can be copied onto clipboard, there is no problem on your environment to use Korean fonts. The problem is the swf file itself and I already explained what happened inside.

To support my investigation, I decompiled the flash control using ShowMyCode and found this:

function init() 
{ 
    system.usecodepage = true; 
    navURL = "http://www.kbs.co.kr/drama/marryme/menu.xml";  
    ....
}

The first line of init() changes System.useCodepage to true, which is a very common mistake to develop a non-English flash control. This means that the control will use your system local code page which is probably not Korean. Unfortunately, the developers did not notice that this would cause a problem as (probably) they used Korean Windows. I strongly believe that software engineers should not use a localised Windows unless they really need it, but it's hard to make a simple conclusion.

I understand why you regarded this as your system's issue because this issue happens on so many Korean web pages. Perhaps it's better to throw a warning or something on the Flash script compilation when a developer is setting that flag to true to warn that this simple code may result in unreadable texts and to motivate them to use Unicode encoding all the time. So, Adobe has a share too, I think.

We have only one choice to resolve this issue - please report this issue to the web administrator. Anything else is a workaround. Would you fix an application bug by yourself, or report it to the developer? It's the same thing. If it's so urgent that you have to read the texts right now, you may take a workaround though - change system locale as I suggested above.

[UPDATE 2]

FYI - As shown above, http://www.kbs.co.kr/drama/marryme/menu.xml has the menu hierarchy you wanted to see so just click this URL and then the Korean characters will be displayed well because the browser itself will decode them even though they aren't Unicode-encoded, if your system is able to show Korean fonts. But this cannot be a permanent solution for you because you should manually decompile other Flash controls.

| improve this answer | |
  • Yes the links are at the bottom of the question. Also there is korean text on those pages that I can copy and paste because they are real text. – Christopher Rucinski Sep 12 '14 at 9:15
  • Hi Christopher, I updated my answer so please take a read. – Scott Rhee Sep 14 '14 at 22:24
0

An option that worked for me was using Microsoft AppLocale Utility.

However, this is a rather old utility. I followed the instructions on the following page to use and install it: http://users.wfu.edu/yipcw/atg/microsoft/applocale/

In short:

  1. Installer must be started as administrator, e.g. from an administrator cmd-window.
  2. Set AppLocale shortcut to XP SP3 compatibility.
  3. Launch AppLocale
  4. Find the Internet Explorer exe, and then choose "hangugo" in hangul.

Here is an example of what it looks like for me, with AppLocale iexplorer.exe on the right: Screenshot of audien

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.